Support » Plugin: Health Check & Troubleshooting » Can’t activate the troubleshooting mode…

  • Resolved YogieAnamCara

    (@yogieanamcara)


    Hello,

    I’m unable to activate the troubleshooting mode as I receive an error message when I try. All directories are writable according the second tab check.

    The main WordPress directory: Writable
    The wp-content directory: Writable
    The uploads directory: Writable
    The plugins directory: Writable
    The themes directory: Writable
    The Must Use Plugins directory: Writable

    However, when I try to activate the troubleshooting mode I get a message as follows:

    We were unable to copy the plugin file required to enable the Troubleshooting Mode.

    Any idea? Unfortunately I’m on a shared hoster and the logs I’ve access to are just limited and not showing anything 🙁

    Cheers
    Yogie

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Marius L. J.

    (@clorith)

    Hiya,

    That’s quite strange, how are you trying to enable Troubleshooting mode, could you take me through the steps you followed up to the error from your Dashboard?

    I simply open the Dashboard -> Health Check, then go to the third tab and try to activate Troubleshooting and the error message is being displayed above the button.

    Plugin Author Marius L. J.

    (@clorith)

    Hmm, interesting, you should’ve gotten a form then to try and login using FTP or similar if permissions would have allowed it.

    Do you have any other files in the wp-content/mu-plugins directory? (or does the directory exist in the first place)

    The mu-plugins contains two files the dir-folder has set to 777 and the files to 640.

    For testing I changeed the permissions and I also checked that the owner of the folders/files is not an FTP user 🙂

    I also removed the files from the folder which did not work either.

    Additonal question is a MultiSite (Network) install supported?
    I saw at the Plugins page that I have a new option at some of the plugins “Troubleshoot”
    However, the plugin itself is still not working, if I click at one of the plugins’ Troubleshoot link I get the same error as above.

    Plugin Author Marius L. J.

    (@clorith)

    Multisite should not be a problem, all the Troubleshooting features rely on the mu-plugin being able to be copied to the correct directory though.

    I must admit, I’m at a bit of a loss as to why it’s running into issues copying for you, what other plugins do you currently have active? (it’s possible to copy the file from wp-content/plugins/health-check/assets/mu-plugin into wp-content/mu-plugins manually, but it would of course be nice to find out why it’s failing as well)

    
    ### Must Use Plugins (2) ###
    
    flush_blogs_rewrite.php: No version or author information available
    ManageWP - Worker Loader: By ManageWP
    
    ### Active Plugins (34) ###
    
    Better Search Replace: Version 1.3.2 by Delicious Brains
    Broken Link Checker: Version 1.11.5 by Janis Elsts, Vladimir Prelovac
    Casper's Flyin' Call-to-Action: Version 1.5.1 by Casey James Perno
    Code Snippets: Version 2.13.2 by Shea Bunge
    Content Views: Version 2.1.3.1 by CVSOFT LLC
    Easy Appointments: Version 2.3.12 by Nikola Loncar
    Events Made Easy: Version 2.1.6 by Franky Van Liedekerke
    Genesis Columns Advanced: Version 2.0.3 by Nick Diego
    Genesis Responsive Slider: Version 0.9.6 by StudioPress
    Genesis Simple Hooks: Version 2.2.1 by StudioPress
    Genesis Simple Sidebars: Version 2.1.0 by StudioPress
    Genesis Translations: Version 2.8.0 by ThemeMix, Remkus de Vries
    Health Check & Troubleshooting: Version 1.2.5 by The WordPress.org community
    Maintenance: Version 3.6.1 by fruitfulcode
    ManageWP - Worker: Version 4.6.3 by ManageWP ( Latest version: 4.6.4 )
    MapPress Maps for WordPress: Version 2.52.1 by Chris Richardson
    Network Plugin Auditor: Version 1.10.1 by Katherine Semel
    Popup Builder PRO: Version 3.1.6 by Sygnoos
    Post Tags and Categories for Pages: Version 1.4.1 by curtismchale
    Regenerate Thumbnails: Version 3.1.0 by Alex Mills (Viper007Bond)
    Shariff for WordPress: Version 1.0.11 by Heise Zeitschriften Verlag / Yannik Ehlert
    Shortcoder: Version 4.3 by Aakash Chakravarthy
    VFB Pro: Version 3.3.8 by Matthew Muro
    VFB Pro - Create Post: Version 2.0.5 by Matthew Muro
    VFB Pro - Create User: Version 2.0.4 by Matthew Muro
    VFB Pro - Display Entries: Version 2.0.5 by Matthew Muro
    VFB Pro - Form Designer: Version 2.0.5 by Matthew Muro
    VFB Pro - Notifications: Version 2.0.7 by Matthew Muro
    VFB Pro - Payments: Version 2.1.4 by Matthew Muro
    Weaver Themes Shortcode Compatibility: Version 1.0.4 by Bruce Wampler
    Widget Importer & Exporter: Version 1.5.5 by ChurchThemes.com
    Widget Shortcode: Version 0.3.4 by Hassan Derakhshandeh
    Wordfence Security: Version 7.2.2 by Wordfence
    WordPress Importer: Version 0.6.4 by wordpressdotorg
    
    • This reply was modified 1 year, 7 months ago by Marius L. J.. Reason: Fix formatting

    I have the same problem and get the same error message when I Enable Troubleshooting Mode. Here is my Debug info:

    
    ### WordPress ###
    
    Version: 5.1
    Language: en_US
    Permalink structure: /%postname%/
    Is this site using HTTPS?: No
    Can anyone register on this site?: No
    Default comment status: closed
    Is this a multisite?: No
    User Count: 1
    Communication with WordPress.org: WordPress.org is reachable
    Create loopback requests: The loopback request to your site completed successfully.
    
    ### Installation size ###
    
    Uploads Directory: 98.33 MB
    Themes Directory: 4.58 MB
    Plugins Directory: 10.63 MB
    Database size: 1.03 MB
    Whole WordPress Directory: 149.38 MB
    Total installation size: 150.41 MB
    
    ### Drop-ins ###
    
    object-cache.php: External object cache.
    
    ### Active Theme ###
    
    Name: Capri Lite
    Version: 1.1.21
    Author: ThemeIsle
    Author website: https://themeisle.com/
    Parent theme: Not a child theme
    Supported theme features: automatic-feed-links, title-tag, post-thumbnails, customize-selective-refresh-widgets, menus, html5, custom-background, custom-logo, custom-header, infinite-scroll, jetpack-responsive-videos, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, widgets
    
    ### Other themes (1) ###
    
    Twenty Nineteen (twentynineteen): Version 1.3 by the WordPress team
    
    ### Must Use Plugins (1) ###
    
    EasyWP Plugin: Version 0.3.3 by Namecheap, Inc.
    
    ### Active Plugins (4) ###
    
    Contact Form 7: Version 5.1.1 by Takayuki Miyoshi
    Health Check & Troubleshooting: Version 1.2.5 by The WordPress.org community
    WPBruiser: Version 3.1.26 by Mihai Chelaru
    WPBruiser - ContactForm7: Version 3.0.9 by Mihai Chelaru
    
    ### Media handling ###
    
    Active editor: WP_Image_Editor_Imagick
    Imagick Module Version: 1689
    ImageMagick Version: ImageMagick 6.9.9-47 Q16 x86_64 2018-05-23 https://www.imagemagick.org
    Imagick Resource Limits: 
    	area: 63 GB
    	disk: -1
    	file: 786432
    	map: 256 MB
    	memory: 256 MB
    	thread: 6
    GD Version: bundled (2.1.0 compatible)
    Ghostscript Version: Unable to determine if Ghostscript is installed
    
    ### Server ###
    
    Server architecture: Unable to determine server architecture
    Web Server Software: nginx/1.14.2
    PHP Version: 7.3.0 (Supports 64bit values)
    PHP SAPI: fpm-fcgi
    PHP max input variables: 3000
    PHP time limit: 300
    PHP memory limit: 1073741824
    Max input time: 60
    Upload max filesize: 256M
    PHP post max size: 256M
    cURL Version: 7.61.1 LibreSSL/2.0.0
    SUHOSIN installed: No
    Is the Imagick library available: Yes
    
    ### Database ###
    
    Extension: mysqli
    Server version: 5.5.5-10.2.16-MariaDB-log
    Client version: mysqlnd 5.0.12-dev - 20150407 - $Id: 401a40ebd5e281cf22215acdc170723a1519aaa9 $
    Database prefix: wp_
    
    ### WordPress Constants ###
    
    ABSPATH: /var/www/wptbox/
    WP_HOME: Undefined
    WP_SITEURL: Undefined
    WP_DEBUG: Disabled
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG_DISPLAY: Enabled
    WP_DEBUG_LOG: Disabled
    SCRIPT_DEBUG: Disabled
    WP_CACHE: Disabled
    CONCATENATE_SCRIPTS: Undefined
    COMPRESS_SCRIPTS: Undefined
    COMPRESS_CSS: Undefined
    WP_LOCAL_DEV: Undefined
    
    ### Filesystem Permissions ###
    
    The main WordPress directory: Writable
    The wp-content directory: Writable
    The uploads directory: Writable
    The plugins directory: Writable
    The themes directory: Writable
    The Must Use Plugins directory: Not writable
    
    
    • This reply was modified 1 year, 7 months ago by Marius L. J.. Reason: Fix formatting
    Plugin Author Marius L. J.

    (@clorith)

    @caite Your problem is not the same, as your Must Use Plugins directory isn’t writable, so that’s something you’ll have to resolve.

    @yogieanamcara I’ve not forgotten you, but the WordPress 5.1 release kind of stole focus and has my attention for the weekend, I’ve not been able to come up with a good solution (or reasoning) for why it’s failing on your end yet though :/

    Hello Marius,

    many thanks! We can do more in depth troubleshooting if you like.

    For the moment I did copy manually. However, I can roll this back and we can do further investigations.

    Cheers
    Joerg

    Thanks Marius. Any ideas how I can fix it? I thought this was automatically managed by the Troubleshooting tool.

    I’ve tried deactivating/activating, then tried deleting/reinstalling/activating but continue to have a non writable Must Use Plugins directory.

    Could it be something to do with my site not being a multisite? I’ve read that the Must Use Plugins directory is for multisites… I’m struggling here…

    Plugin Author Marius L. J.

    (@clorith)

    @caite This is another users topic, please open your own topic and I’d be happy to help you 🙂

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Can’t activate the troubleshooting mode…’ is closed to new replies.