WordPress.org

Support

Support » How-To and Troubleshooting » Can’t activate plugins

Can’t activate plugins

  • When I click on a plugin It says “Plugin Activated” but they never actually activate. I can click it over and over and It just says Activated, never Deactivated or anything other then that it was activated. I don’t know if it is because after installing it at http://www.mydomain.org/wordpress/ i moved it to the root http://www.mydomain.org.. but everything else works great.

Viewing 9 replies - 1 through 9 (of 9 total)
  • did u fixed the paths after moving wp from a folder up?

    yes i did. in the options. is there one in the database?

    Mark (podz)

    @podz

    Support Maven

    Did you do everything here as well ?
    http://wordpress.org/docs/installation/different-address/

    No, that is not the same as what I have done. I have moved ALL FILES down one directory in the tree. I’ve made all changes in the configurable options from the Admin login. The plugins still do not activate.

    Ok, i think this is a branch off the Login error.
    there was a modification needed in the wp-login.php to properly allow it to access the database. it’s in the wrong format.
    Example:
    Fatal error: Cannot use object of type stdClass as array in D:\www\wp-admin\upgrade-functions.php on line 705
    Now, the problem has been fixed in the login but I believe it may be through out the code and this is preventing any sort of changes to the database when it comes to admin settings. I don’t know though because posting and those functions are fine. I just got that error when I attempted to use the upgrade.php to see if it could help.

    Official problem is i’m a idiot who left PHP5 on rather then PHP4 🙂
    ——–
    YES PEOPLE WHO VISIT THIS POST WITH THE SAME PROBLEM…
    CHANGE TO PHP4 THEN USE THE update.php IN THE /wp-admin/ FOLDER AND ALL WILL BE FIXED!
    ——–
    Plugin activated
    Deactivate
    YAY!

    Hi guys, I seem to have this same issue but I can’t revert back to PHP 4. Any one has any idea on how to solve this?

    Thanks

    PHP5 users:
    change line 705 in /wp-admin/upgrade-functions.php into

    if ($res[0]->Type != ‘varchar(32)’)

    run /wp-admin/upgrade.php //not update as written above

    thats all…

    duschata, you are a genius! Worked like a charm! After fixing upgrade.php and running it, plugins now work and can be activated. Also an issue about comments always going into moderation was fixed.

    I am amazed by the quality and the size of the WP community. I have found several issues with WP, but all of them were addressed here at the forums by previous or new posts. Can’t argue against that! If you compare that with what you get say for instance when you buy Windows, you start to understand why the Open Source wave will succeed.

    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can’t activate plugins’ is closed to new replies.