Support » Plugins » Can't Activate Plugin: Your WordPress database is already up-to-date!

  • Hi All,

    I’m writing a plugin, but I seem to have done something wrong that I cannot figure out. When I try to install my plugin, the install works fine, but when I click the “Activate” link, I get a message that says: “Your WordPress database is already up-to-date!”. However, the plugin does not become active.

    I have tried removing the plugin and reinstalling. I’ve tried bumping the version number in my plugin-name.php file and “Upgrading” but every thing I try I still get the database is up-to-date message and an inactive plugin.

    Any suggestions?


Viewing 4 replies - 1 through 4 (of 4 total)
  • Finally figured out my problem!

    The issue was that I had:


    to include my admin options page. I must have hit a namespace collision or something.

    Have just updated to latest WP version, 3.3.

    It seemed to be fine on the first domain, but on the second I can no longer make admin function. Once I get into admin, if I try do do just about anything I get the message
    “No Update Required

    Your WordPress database is already up-to-date!”

    Pressing Continue returns me to the front page of the site, so I log back in and the process repeats. Have tried deactivating htacces and renaming upgrade.php.


    It came good after a bit of fiddling, don’t know why. Possibly a cache issue.

    Hi brough,

    I think that you are experiencing a different problem than the one I was having while writing a plugin for Word Press. Glad you were able to get your sites working again.


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can't Activate Plugin: Your WordPress database is already up-to-date!’ is closed to new replies.