Support » Plugin: Woocommerce Google Feed Manager » Can’t activate plugin

  • Resolved Dave Dean

    (@deaner666)


    I can install the plugin, but when I try to activate it I get:

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected ‘[‘ in /nas/content/staging/prismdesign/wp-content/plugins/wp-product-feed-manager/includes/application/class-feed-master.php on line 737

    I’ve tried deactivating all non-essential plugins in case there’s a conflict but it still won’t activate.

    Hosted on WP Engine. PHP version is 5.3.10, which I guess could be the issue as the syntax error seems to be to do with a multi-dimensional array assignment?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Hi Dave,

    Could you please try to completely remove the plugin and then download and install it again? It seems as if the software download was not correct.

    OK I’ve tried that but I’m receiving exactly the same error on activation.

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Could you download the following file:

    https://dl.dropboxusercontent.com/u/3129817/class-feed-master.php

    and place it in your nas/content/staging/prismdesign/wp-content/plugins/wp-product-feed-manager/includes/application/ folder, overwriting the old file?

    Then check again and please report back the result.

    Hi Michel,

    I actually had the server upgraded to PHP5.5 before you sent me the file. The plugin works fine with 5.5.

    However, I’ve conducted a test on a local dev site with the PHP version set to 5.3 and I got the same error with the public version of the plugin. I then updated class-feed-master.php to your updated version in this thread and that made the plugin work even on 5.3.

    Hope that’s useful.

    Cheers,

    Dave

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Dave,

    Yes that helps. The plugin has worked with 5.3 before but I will have a look in the archives if the code that causes the error maybe has been implemented recently and that it therefore has not been reported before.

    Glad it works now.

    Could you please change the status of this topic to resolved?

    Michel

    I am having the same problem when activating plugins. This is a new issue. I am running PHP 5.2 on my site but the plugin installs and activates on a subdomain just fine. I had to manually delete the plugin as it would not delete in WP, it just hung there saying deleting…..

    Installation works fine, it’s the activation that is the problem.

    The error is:

    Parse error: syntax error, unexpected T_STATIC, expecting T_STRING or T_VARIABLE or ‘$’ in /home1/noworri6/public_html/lfkearney/wp-content/plugins/WP_Estimation_Form/includes/MailPoetList.php on line 28

    The plugin is:

    https://codecanyon.net/item/wp-cost-estimation-payment-forms-builder/7818230

    • This reply was modified 3 years, 8 months ago by lfkearney.

    Hi @michel-jongbloed, i think i have the same problem.. can you share me the”https://dl.dropboxusercontent.com/u/3129817/class-feed-master.php” mentioned please?

    First, mi problem is “Parse error: syntax error, unexpected T_STRING in” trying to activate wp-staging plugin.

    wp version 4.8
    staging 2.0.6

    THANKSSSS!!!

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Hello @opsia,

    What version of our plugin do you have? The latest version should have this fix included so you should already have this class-feed-master.php file.

    But are we talking about the wp-staging plugin or about our wp-product-feed-manager plugin?

    Staging version: 2.0.7
    And is the wp-staging plugin.

    I’ve tried deleting and reinstalling without problem, but can’t activate

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    OK @opsia,

    But this is not the support forum for wp-staging. I have nothing to do with that plugin. Please report your issue here: https://wordpress.org/support/plugin/wp-staging

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can’t activate plugin’ is closed to new replies.