Support » Theme: Customizr » Can’t activate frontpage meta using yoast seo

  • Hello. Does anyone know or at least try to activate FrontPage titles and metas for this theme, using Yoast Seo?
    When i go into Titles and Metas -> Homepage i have only this message: “You can determine the title and description for the front page by editing the front page itself”. If i click it it just reloads the page.
    Any help would be appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I Have the same problem, man

    Denzel, it is already enabled and still doesn’t shows the frontpage meta.

    Hi @florinst1,

    If you are using a cache plugin or server cache, you will need to clear it’s cache content.

    Clear your browser history.

    Check that you are using only one SEO plugin. You cannot use multiple plugins with the same functionalities.

    Look into your homepage source code, you should see the title and meta description.

    Thank you

    Thanks for the reply Denzel, but still doesn’t show.
    Anyway, i looked a little closer in Yoast’s code (/wp-content/plugins/wordpress-seo-premium/admin/views/tabs/metas/home.php) and saw this:

    if ( 'posts' == get_option( 'show_on_front' ) ) {

    In wordpress wp_options table if i set show_on_front = posts (with this setting, customizr pro is showing latest articles on front page) i also get the homepage meta description and keywords and it is also enabled in the Admin panel. So with this setting everything is fine, but the problem is i don’t want to enable latest articles on my homepage 🙂

    L.E: because the default value of “show_on_front = nothing”, an unorthodox way to make it work without activating posts on frontpage is to modify in yoast plugin “/public_html/wp-content/plugins/wordpress-seo-premium/frontend/class-frontend.php” line 218 to:
    return ( is_home() && 'nothing' == get_option( 'show_on_front' ) );
    and “(/wp-content/plugins/wordpress-seo-premium/admin/views/tabs/metas/home.php” line 12 to:
    if ( 'nothing' == get_option( 'show_on_front' ) ) {

    This will make it work, until maybe in the future will be fixed.

    • This reply was modified 2 years, 5 months ago by  florinst1.
    • This reply was modified 2 years, 5 months ago by  florinst1.

    Thank you for sharing this information.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can’t activate frontpage meta using yoast seo’ is closed to new replies.