Support » Plugin: Disable XML-RPC Pingback » Can’t activate Disable XML-RPC Pingback plugin

  • Resolved Ya-Yo Gakk

    (@ralphort)


    Installed the plugin but gets fatal error during activation…

    Fatal error: Cannot redeclare sar_remove_x_pingback_header() (previously declared in /volume1/web/wordpress/wp-content/mu-plugins/disable-xml-rpc-pingback.php:35) in /volume1/web/wordpress/wp-content/plugins/disable-xml-rpc-pingback/disable-xml-rpc-pingback.php on line 35

    Checked disable-xml-rpc-pingback.php on line 35 & found this…

    add_filter( 'wp_headers', 'sar_remove_x_pingback_header' );
    
    function sar_remove_x_pingback_header( $headers ) {
       unset( $headers['X-Pingback'] );
       return $headers;
    }

    WordPress is installed on virtual host via WordPress app on Synology web server running at home. I’s new to WordPress but do I really need this (must use) plugin per WordPress & how without getting this fatal error?

    • This topic was modified 2 years, 1 month ago by Ya-Yo Gakk.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Samuel Aguilera

    (@samuelaguilera)

    Hi,

    That error is indicating you that you already have the plugin installed as a mu-plugin in /volume1/web/wordpress/wp-content/mu-plugins/

    So you don’t need to install it from the Plugins page.

    Only one instance of the plugin can be enabled.

    Regards.

    Ok, thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can’t activate Disable XML-RPC Pingback plugin’ is closed to new replies.