Support » Plugins » Can't activate any plugins

  • Resolved sebastianbarfurth



    I’m facing a problem. I’ve been searching but there’s been no solution, so I’ll post my own topic.

    I’ve recently installed WordPress, added WooCommerce and a theme from WooThemes, worked fine. I installed a few plugin, just from the “Add New” section and searching for them.

    Now today, suddenly, out of nowhere (at least I don’t know why) activating plugins doesn’t work anymore.

    If I download a plugin it downloads, unpacks and bla bla and I hit activate, but it just tells me that the header is broken. (“The plugin does not have a valid header.”)

    When I go into my FTP client now there’s no folder for the plugin within wp-content/plugins, nothing at all. It’s not on installed plugins (not as deactivated either), there’s nothing.

    Now I tried to install that same plugin again, should work, right? No. It said: The folder for that plugin already exists, which clearly isn’t the case, it’s nowhere. I even tried installing manually after, that was the only way it worked, but no files had to be overwritten, I don’t know where WordPress gets that the folder already exists.

    I don’t want to install every plugin manually, that takes up too much time, is there any fix for this?

Viewing 2 replies - 1 through 2 (of 2 total)
  • I solved this myself.

    Just in case anybody faces similar problems: WordPress thought it was funny to create a new “root”-structure within the WordPress root, there was my normal structure “www/httpdocs/wordpress/wp-content/plugins” and what it did is create the following path “www/httpdocs/wordpress/www/httpdocs/wp-content/plugins”. Deleting the second set of “www/httpdocs/wp-content/plugins” withing the WordPress root fixed the issue.

    Thank you. This was really driving me nuts.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can't activate any plugins’ is closed to new replies.