Support » Fixing WordPress » Can’t access WP-Admin with client details

Viewing 11 replies - 1 through 11 (of 11 total)
  • From what I observed, the usernames and password that were given is still not correct. If you have access to the domain hosting panel, you can change the password of that username in the database. You just need to go to the phpmyadmin settings and modify the user password there.

    Hope this helps your concern.

    Thread Starter Jose

    (@josefaarseth)

    Well, apparently the .htaccess of the site blocked my IP and I’m unable to access anything. Not the front page nor the login panel.

    Hey Josef!

    It sounds to me like you don’t have a valid username and password. Can your client log in with the credentials they’ve given you? If not, you can reset the password using techniques in the following guide:

    https://codex.wordpress.org/Resetting_Your_Password

    I would recommend ensuring you have valid login credentials before troubleshooting this further. Unfortunately, customers can’t always be trusted to know their own username/password.

    Assuming you have valid credentials and you still can’t get in, there is likely a security related plugin blocking access. Can you specify what security plugins are in use? Have you tried disabling them?

    • This reply was modified 6 years, 3 months ago by dabame.

    As @dabame suggested, it most likely is a security plugin blocking you. Your best bet is to wait it out, or connect via a different IP (i.e. a different WiFi network).

    However I wanted to add because it was suggested above but without any instruction, that should you need to change the password directly in the database (which is most likely what you will need to do) it is VERY important you follow the exact steps as outlined in the link that @dabame gave you. The password must be inserted as an MD5 hash.

    I’m going to renege on the database method due to the fact that bad things could happen if you make a mistake.

    Forget about accessing the WordPress admin panel. Go to your web host and use phpMyAdmin to access the database and find the user ID for the admin account. On the page that @dabame referred you to, follow this method https://codex.wordpress.org/Resetting_Your_Password#Through_FTP

    To disable any security plugin, you could also use the file explorer within your web host’s control panel to find and disable any suspect plugins simply by renaming the folder of the suspect plugin.

    Good luck!

    Thread Starter Jose

    (@josefaarseth)

    Thanks everybody! I’ll ask my client access to his database and FTP server to check everything out. I also requested a screenshot of the plugins page to see which plugins is he using. If I need further help I’ll let you all know!

    Go to the phpmyadmin and change your password.

    Read more about how to change password using phpmyadmin:

    http://wpcrux.com/change-wordpress-password-phpmyadmin/

    If your IP is blocked then try to access the wp-admin from another ip address and then login to wp-admin with the new set of username and password.

    Thread Starter Jose

    (@josefaarseth)

    What’s this WordPress version? My client just sent me a screenshot of his Worpress admin but I have no idea what this is…

    • This reply was modified 6 years, 3 months ago by Jose.

    When this happened to me, the problem was eventually tracked down to the mod-security setting in the client’s cpanel. See if there is such a feature in the client’s hosting and disable or bypass it for your IP.

    You will still need to deal with any block in .htaccess, any security plugins that have locked you out and have the right credentials.

    The screenshot looks like a wp.com site. If so, this may make it easier because your client can go to wp.com support and ask for you to be setup as an admin for his site.

    Thread Starter Jose

    (@josefaarseth)

    Yep, I think my client is giving me the wrong login credentials.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Can’t access WP-Admin with client details’ is closed to new replies.