WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't access wp-admin area (4 posts)

  1. mmwaa
    Member
    Posted 2 years ago #

    When I login to access the admin area on my blog I get the following message instead of access:
    Fatal error: Call to a member function add_help_tab() on a non-object in /home/coo1169/public_html/blog/wp-admin/index.php on line 40

    Line 40 reads: </div><!-- dashboard-widgets-wrap -->
    index.php hasn't changed, as far as I know.

    I am using V 3.4.2. My blog is hanging off in my main site at cookingdownunder.com/blog/ Usually I can sort things out but I have no idea where to start this time :(

    Thanks if anyone can give me some guidance

  2. mmwaa
    Member
    Posted 2 years ago #

    Correction here -

    Here are lines 37-46:

    // Not using chaining here, so as to be parseable by PHP4.
    $screen = get_current_screen();

    $screen->add_help_tab( array(
    'id' => 'overview',
    'title' => __( 'Overview' ),
    'content' => $help,
    ) );

    // Help tabs

    Still no joy.

  3. Have you tried downloading a fresh copy of WordPress and re-uploading all of the contents from the wp-admin.

    If that doesn't work

    Have you tried:
    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the 2010 theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  4. mmwaa
    Member
    Posted 2 years ago #

    Thanks, Christine. I was pondering the wisdom of reloading from a fresh copy of WordPress so you gave me the necessary nudge. It worked. The only way I could deactivate the plugins was to rename the folder so now that I am back in on the admin side, I can deactivate them and check them one by one.

    Bless you! My immedate problem has been resolved :-)

Topic Closed

This topic has been closed to new replies.

About this Topic