Support » Localhost Installs » [Resolved] Can't access wordpress site in localhost

[Resolved] Can't access wordpress site in localhost

  • Hello ,

    I have installed wordpress on Localhost recently so that I can test some plugins and themes in it. I Installed LAMP server in my debian and installed wordpress over it. Now I can access wordpress and admin login and everything of that sort but can’t get the site. I mean, if I go to http://localhost , it shows only like this :

    It works!

    This is the default web page for this server.

    The web server software is running but no content has been added, yet.

    I have added themes, plugins and also some post but I can’t see any of them in localhost. Could someone help me with this issue ?

    Thanks !

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hey, you should remove a file called index.html or index.htm from your site root. This should fix the problem.

    Thank you so much.. It worked. Can you tell me why should we remove it ?

    You had two index files in your site root: index.html (that Apache one) and index.php (the WordPress one). Thus, the web server was recognizing the html one instead of the php one.

    Ooh yeah. Now I got it. thank you so much !

    If you can, never remove that index.html file. It is our default file to test our server.

    It works!

    This is the default web page for this server.

    The web server software is running but no content has been added, yet.

    That means our web server is working.

    You can install wp on root folder & access them via http://localhost by removing that index.html file.

    But I sugest to make new folders inside your root folder, install WP etc on that folders & access them via http://localhost/yourfoldername url.

    This method is better because you have too many web applications to test in feature.

    I am having a similar problem using WAMP with Windows 7 64 bit. When I type localhost/myfile I get at the top Index of /myfile. Next line reads:
    Name Last modified Size Description

    Third line: Parent Directory
    Fourth line: wordpress/ (followed by date and time)

    Any help would be appreciated.


    The forum rules require you to start a new thread. You are very fortunate that anyone happened to read this thread at all since it is marked as “resolved”.

    From what you have said your website address is:

    I strongly suggest that rather than using localhost as your webserver name, that you go to the minimal extra trouble of configuring apache to use a “VirtualHost”, it will do you good to find the answer in this forum, I solved a problem similar to this yesterday.

    In debian 7 with LAMP server running.
    What I did was have the path to extracted wordpress.zip (downloaded) pasted in the default file in /etc/apache2/sites-available/

    That is essentially replacing /var/www to the wordpress directory structure.

    DocumentRoot /home/user/mywordpress/

    <Directory /home/user/mywordpress>

    Is this an OK way of doing it?

    Hello @ajeya, yes that probably is OK, you have not really supplied enough details.

    You really should start a new thread of your own.

    Thanks for your response Ross. I’ll repost.

    Some time It happens when running localhost meanwhile skype application is running.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Can't access wordpress site in localhost’ is closed to new replies.