Support » Networking WordPress » can't access the dashboard of networked sites

  • Resolved hkcharlie

    (@hkcharlie)


    I recently moved my WPMS install to a new server.
    All my domains are mapped and my websites can be seen from the front end, I can access the dashboard for my main site and the network, but when I try to access the dashboards of my networked sites I get redirected to :

    http://mysite.com/cgi-sys/index.html

    which is a plain white page.

    Any ideas

Viewing 10 replies - 1 through 10 (of 10 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Do not make folders for your mapped domains on the new server.

    Thanks for the idea, but I dont have folders.

    Have you created blog.dir directory?
    Have you written

    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    in wp-config.php ?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    This http://mysite.com/cgi-sys/index.html is a server error.

    Blogs.dir isn’t the issue. Your .htaccess and/or your subdomains are.

    What kind of site do you have> Subdomain or subfolder?

    sub folder, I believe. All the addresses are like this: /childsite_1/ etc

    On my old server the main multisite install was in a sub folder, now I have moved it to a new host it’s in the root.
    Could it have something to do with this ?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    *sigh* yes. Did you follow these directions: http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Multisite

    A couple of things.

    1.
    the path for the main blog is http://mainsite.com , for the child blogs listed in the options tables http://mainsite.com/childsite/
    this looks all ok to me.

    but I’m not sure about the upload_path which looks like this :
    wp-content/blogs.dir/25/files

    2.
    the guide says “If you’re moving Multisite from one folder to another, you will need to make sure you edit the wp_blogs entries to change the folder name correctly. You should manually review both wp_site and wp_blogs regardless, to ensure all sites were changed correctly.”

    I cannot find anything (folders or tables) that are called “wp_site” or “wp_blogs”

    3.
    While sniffing around the tables I found a few references with the path to the old server. I used the search/replace tool and corrected these. My problems still persist.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    They’re tables in your DB.

    If you don’t have tables in your database called wp_blogs and wp_site, then you’ve got problems.

    Do not touch the upload path. Ever. Leave it the heck alone, please I beg of you.

    OK, forgive me, I’m finding my feet at this depth.

    My database prefix is “dbb” not “wp” and the tables I was searching for were on the second page of the tables list, which is why they didn’t show before.

    SORRY!

    the bdd_site table shows only two sites, both their own domains are stipulated and the path both show to the root (this is identical to the setup that was on my old server)

    the bdd_blogs is again identical to how it was on my old server.
    In the domain column they all have “mysite.com” and in the path column they all have “/mychildsite/” which appears to make sense and be correct to me.

    I then looked at my .htaccess file

    (reminder: what has been happening is that I can go to my “childsite.com” as it’s apparently mapped and shows perfectly well. If then try to go to “childsite/wp-admin/ it tries to redirect to the login page and then eventually to “http://totalsoccerschools.com/cgi-sys/index.html”
    I cleared my .htaccess out and put in the min required for sub folders based on this
    http://codex.wordpress.org/Multisite_Network_Administration#.htaccess_and_Mod_Rewrite

    when I tried this time to go to “childsite.com/wp-admin/” the result was something completely different and unexpected. It redirected me to
    http://mymainsite.com/members/admin/activity/friends/

    This reminded me that I have a redirect plugin for the buddypress homepage, so I could assume that something was associated with the plugins.

    I renamed the plugins folder and tried loggining in to the dashboard of my childsite again and I got in.

    First: Andrea Rennick posted the comment “Do not make folders for your mapped domains on the new server.”

    If folders should not be used, why is listed as an option in the install?

    Second:
    I installed a few times, could not get to the sub-site dashboard.

    I had
    define(‘SUBDOMAIN_INSTALL’, false);
    set in the wp-config, per another post I looked at (I wanted a folders setup).

    Changed that to true and can now get to the networked site dashboard.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘can't access the dashboard of networked sites’ is closed to new replies.