Support » Fixing WordPress » Can't Access Site? Can't Even Access Login!

  • Resolved prayersnapples

    (@prayersnapples)


    I was trying to add a favicon to my site and I followed instructions I found online that said to add to the functions php:

    function my_favicon() { ?>
<link rel="shortcut icon" href=" http://www.prayersandapples.com/wp-content/uploads/2013/01/favicon1.ico " >
<?php }
add_action('wp_head', 'my_favicon');

    I did that and immediately this message came up:

    Parse error: syntax error, unexpected ‘}’ in /home/prayersnapples/prayersandapples.com/wp-content/themes/freedream/functions.php on line 10

    So I tried to press the back button and it wouldn’t let me! It just keeps giving me this same message. I tried going to my login page and the same message appears there. I have no way to access my site! Is my entire blog gone?! What do I do?

    http://www.prayersandapples.com

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m googling things right now and I think I might have do something with my host? I’m with DreamHost if that helps…

    To whoever might respond I (obviously) have no clue what I’m doing, so if you could please break down even the most basic steps. I’m reading a lot about FTP (don’t know what that is?) and suggestions that I download or upload files again – I don’t even know where to start with that? I did install a backup plugin a couple weeks ago that uses Google Drive.

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Ask your host for your File Transfer Protocol (FTP) credentials and then use software like FileZilla to connect and gain access to your website’s folders and files.

    Ok i got the passwords and I downloaded FileZilla and I see the folders – now what? I know the only problem is those couple lines i added in the functions.php – do I just try to find those in these new folders and delete them? (thank you so, so much for helping me by the way!!)

    IT WORKS!! I did exactly what you said… then I found my functions.php file that i had from my backup and i drug it over to the files – a window popped up saying “a file with that name already exists, do you want to overwrite it?” and I said yes… and then tried to open my website and it worked! thank you so much. is there anything else i need to do (any loose ends to tie up from that process) or should i be all set now? (thank you again!)

    everything’s fixed! 🙂

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Excellent work 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can't Access Site? Can't Even Access Login!’ is closed to new replies.