Support » Plugin: BulletProof Security » Can't access Settings menu for BulletProof Security

  • Resolved Carlo Rizzante


    All suddenly today I discovered to be unable to access the Settings page for BulletProof Security. I’m working on a Multisite, where the plugin is activated on the primary site.

    When I try to open the BPS Settings Page I receive an error.

    You do not have sufficient permissions to access this page.

    I searched everywhere for a solution and I tried already to fiddle with phpMyAdmin and capabilities and roles. It did not help.

    I created a new SuperAdmin, but it has the same issue than the original User #1 of the Network.

    Honestly, after hours, I feel lost. Can’t find a solution. The plugin works, but I cannot set it up or change settings any more. I can still deactivate/activate it at will.

    The problem is limited to the BPS plugin. All other plugins seems to work fine.

    For the record, today I have also activated the Multisite Plugin Manager. Which gave me a white screen of death right after activation. May the two things be correlated? Hopefully not…

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author AITpro


    You do not have sufficient permissions to access this page

    Ok keep it simple and logical and avoid the deep end of the pool. 😉
    This is a standard/default WordPress error message above.

    The most logical conclusion based on your info is the new plugin introduced into your environment is hooking into WP caps, etc. and is triggering the error. Try the most basic thing first. Deactivate this new plugin and then see what happens.

    Plugin Author AITpro


    I will install the Multisite Plugin Manager, check the code, run some tests and post back here with results.

    Plugin Author AITpro


    The code looks clean minus some issues such as $wpdb->get_col should be using WP prepare. The lack of code had me a bit worried, but this is a new plugin so it is in the “building” stage of development. Overall the code looks good though. Will test the plugin…

    Plugin Author AITpro


    Ok I take it back. Find another alternative plugin. This plugin is not “safe” (from an industry standards point of view) to use. I am unable to test it on XAMPP – produces a blank white page When trying to access the testing site and before even getting to being able to login and activate the plugin so I did not look any further on why that problem is occuring.

    In fact, Multisite Plugin Manager gives me the white screen as well (on different Multisites online – while in local it apparently works).

    Meanwhile, thanks for your support and prompt reply.

    Unfortunately, once I deactivated Multisite Plugin Manager I noticed (few hours later) that the Settings page for BulletProof Security disappeared from the Dashboard.

    I played around creating a new super admin, or resetting user roles and capabilities even into the database via phpMyAdmin. With no luck so far.

    For the record, few hours earlier I also upgraded BulletProof Security. In fact the reason why I wanted to go to Settings for BPS was that the Admin area presented the big yellow message on top from BPS itself, reminding to do something after the update.

    I did some test in local, and apparently the activation and deactivation of Multisite Plugin Manager did not disable the BPS Settings page. I just got the white screen and had to rename or delete the folder of the MPM plugin entirely to get back to the Admin area. But with no visible consequences.

    Plugin Author AITpro


    Well maybe the Multisite Plugin Manager author would be willing to fix whatever is wrong with this plugin, but it would just be simpler to find another plugin that does the same thing that is working already. 😉

    Yes, very true.

    But honestly I’m afraid that MPM plugin hasn’t much to do with the broken Setting BPS page. Or, anyway, I can be sure about. I would say 50/50.

    Right now the BPS works, and it does an excellent job. I’m very happy with it. And I’m very up for upgrading to the Pro version. If I do, and I still will have the permission issue, will I have a bit of support in understanding where to put my hands in the dirt and fix the code?


    Plugin Author AITpro


    BPS was working on this site before correct? And then it just stopped working all of a sudden?

    Delete your Browser cache.
    Delete plugin cache if you have a caching plugin.
    Deactivate plugins one by one and test.
    Switch your theme to the WordPress 2013 Theme and test.

    Plugin Author AITpro


    Also I believe this wp-config.php Constant might cause this problem since it would probably block the BPS htaccess File Editor from being able to edit .htaccess files. Check your wp-config.php file for this Constant.

    define( 'DISALLOW_FILE_EDIT', true );

    If all of the things did not work then Uninstall/Reinstall BPS.

    it is something in the theme I’m developing that disables the Settings page of PBS. So I am personally the culprit.

    Thanks for suggesting me where to look at. I didn’t think about switching to an alternative theme.

    Solved 🙂

    ps. I’m gonna purchase the Pro edition of BPS anyway. Cool plugin and great support. Thanks for it.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Can't access Settings menu for BulletProof Security’ is closed to new replies.