Support » Plugins and Hacks » [Resolved] Can't access plugin options

[Resolved] Can't access plugin options

  • Hello,

    I can’t access any options of this plugin. Only page I can view is /wp-admin/admin.php?page=backwpup, anything else generates You have insufficient privileges to view/access this page.

    /wp-admin/admin.php?page=backwpupeditjob – unable to access
    /wp-admin/admin.php?page=backwpupsettings – same

    I’ve tried reinstalling plugin but it didn’t help. Other versions (tried also last 2.x) also do not work.

    I’m head admin.


Viewing 15 replies - 1 through 15 (of 21 total)
  • I am also seeing this behavior.

    WordPress 3.5.1
    BackWPup 3.0.6

    Plugin Author Daniel Hüsken


    Please test if there another Plugin that causes that.

    Running BackWPup as single plugin didn’t help, still having this issue.

    Same issue here…

    Whatever i try to acces, i get: “You have insufficient privileges to view/access this page” or in dutch “Je hebt onvoldoende rechten voor toegang van deze pagina”

    WP 3.5.1
    BackWPup 3.0.6

    Please keep me posted about a solution

    Same problem here

    The plugin stops sending backup to any of my storage after i upgrade to version 3.0.6 and also i can not edit nor create new jobs the error says “You do not have sufficient permissions to access this page”. but i am the administrator of the site. and also i have tried disable all of my plugin except backwpup but still not working


    I’ve had this same issue since upgrading to 3.0.x. No backups run, and BackWPUp isn’t visible in the network admin. Going to /wp-admin/network/admin.php?page=backwpup leads to an insufficient privileges message. Rolling back to 2.1.17 fixes the issue. It’s been driving me insane for days.

    After hours of digging, it doesn’t seem to actually be a roles/capabilities issue, and not actually a BackWPUp problem. The culprit line for me was line 66 of backwpup.php: “if ( is_multisite() && ! is_main_site() )” The call to is_main_site() is returning false when it should be true, because the global $current_site variable doesn’t have the blog_id set. It should be set to the ID of your main blog, usually 1.

    Not sure yet why this is happening. But a quick workaround is to remove that conditional in backwpup.php (and the line after it), or to manually set your $current_site->blog_id to whatever your main blog ID is. Be careful: both may lead to unexpected results, and changes to a plugin file will be erased every time you upgrade the plugin.

    Turns out it was an issue with my sunrise.php that didn’t properly set the $current_site->blog_ID which screwed up the WP is_main_site() call.

    I am still seeing this behavior after upgrading to BackWPup Version 3.0.8. Is everyone in this thread using WordPress’ Multisite capability?

    Nope, I’m using multiple single sites config.

    Plugin Author Daniel Hüsken


    die you have installed the Advanced Acsses Manager ?
    see http://wordpress.org/support/topic/you-do-not-have-permission-to-access-this-page-5 .

    No, here are the plugins I am using. I tried disabling them all and I still get the same behavior.

    Akismet Version 2.5.7
    BackWPup Version 3.0.8
    Crayon Syntax Highlighter Version 2.2.0
    Google Analytics for WordPress Version 4.3.3
    WordPress SEO Version 1.4.7
    WP Super Cache Version 1.3.1

    Plugin Author Daniel Hüsken


    So i have improved the roles in the plugin. In the next version you can setup with role for BackWPup will used in the user settings. I hope that resolves the problem.

    Although i get rid the admin access manager plugin but the backwpup still not working i dont know what happen. I think there are catch files in there

    Upgrade to 3.0.10 didn’t solve problem 🙁

    Hi Daniel,

    The update / upgrade to 3.0.10 didn’t resolve any of the problems. It only made them worse… After updating only the BackWPup plugin and nothing else, my whole website crached and i had to restore everything from previous manual backups. I’ve even tried the update twice to check if it could have been anything else but i’m quite sure it couldn’t have been.

    At first your plugin was realy great but after all these issues lately i’ll have to deactivate and remove it completely. Hope you’ll find a fix and can restore it to its former glory

    Please re-open this topic since the issue isn’t resolved and the 3.0.10 version could possibly create more serieus issues for other users as well.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] Can't access plugin options’ is closed to new replies.