Support » Fixing WordPress » Can’t access pages after setup on new server

  • Hiya.
    I just moved our wordpress setup from one server to another. At first sight, everything works fine: I can access the home page and wp-admin. However, once I click on a page-link, I end up with a 404.
    I can edit pages from the backend and checked their permalinks and they look fine (<ip>/userdir/wpdir/pagename/).
    Any idea what might be causing this?
    Thanks a lot,
    Tassilo

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    How are you hosting this site? If this is your own VPS, check the virtual host settings for this site and add the following 3 lines:

    <Directory /path/to/wordpress/installation>
       AllowOverride All
    </Directory>

    then restart apache/httpd.

    Thank you, but unfortunately, that didn’t fix it. The page is hosted on a VPS, yes.
    Here’s the setup (had to exchange the domainname for <url> here):

    # vhost_start <url>.com
    <VirtualHost <ip>:80>
    	ServerName <url>.com
    	ServerAlias www.<url>.com
    	ServerAdmin webmaster@<url>.com
    	DocumentRoot /home/www/public_html/gain
    	UseCanonicalName Off
    	ScriptAlias /cgi-bin/ /home/www/public_html/gain/cgi-bin/
    
    	# Custom settings are loaded below this line (if any exist)
    	# Include "/usr/local/apache/conf/userdata/www/<url>.com/*.conf
    
    	<IfModule mod_userdir.c>
    		UserDir disabled
    		UserDir enabled www
    	</IfModule>
    
    	<IfModule mod_suexec.c>
    		SuexecUserGroup www www
    	</IfModule>
    
    	<IfModule mod_suphp.c>
    		suPHP_UserGroup www www
    		suPHP_ConfigPath /home/www
    	</IfModule>
    
    	<Directory "/home/www/public_html">
    		AllowOverride All
    	</Directory>
    
    	<Directory "/home/www/public_html/gain">
    		AllowOverride All
    	</Directory>
    
    </VirtualHost>
    # vhost_end <url>.com
    • This reply was modified 1 year, 2 months ago by  Steve Stern.
    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Do you have an .htaccess file in the site’s docroot? Also, have you tried resetting your permalinks?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Can’t access pages after setup on new server’ is closed to new replies.