Support » Plugin: OpenHook » Can't access open hook with admin user (me too)

  • Hello – I cant access openhook admin screens. I’m logged in as an admin with all privileges. The hooks created are all working it seems. On Thesis 1.8.6 and WordPress 4.5.3, Openhook 4.2.1. I have disabled all other plugins, including security related plugins, to no avail. I have re-installed Openhook files, re-installed wordpress files without success. I’m not sure where to go from here.

    Obviously this worked for me at some point. Through various upgrades something broke. I don’t know when it stopped working.

    Thanks

    https://wordpress.org/plugins/thesis-openhook/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter handyguyspodcast

    (@handyguyspodcast)

    Upgraded to Thesis 1.8.7 and same issue. Any thoughts?

    Same here, even after upgrading to Thesis 1.8.8

    I had the File Editor disabled with this line in the wp-config.php:

    define(‘DISALLOW_FILE_EDIT’, true);

    Once I commented out that line then OpenHook worked again.

    Plugin Author Rick Beckman

    (@brazenlygeek)

    That is by design. The nature of OpenHook allows similar control over a site as would editing actual files. A site locked down against file changes should not allow OpenHook to run either.

    I admit the idea isn’t perfect, but given that the thing runs arbitrary PHP, I had to include some safeguards. I’m open to suggestions.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can't access open hook with admin user (me too)’ is closed to new replies.