Support » Networking WordPress » can't access newly created sub-domains

  • I am having issues visiting my sub-domain sites (e.g. site.website.com). Everything went fine during installation of MS, but after I created my sub-domain sites I visited them and Google Chrome says they don’t exsist? I cant even get access the their dashboards, except for my main site. I do have “mod_rewrite” enabled and I have the Wildcard sub-domain (e.g. *.website.com) in my DNS records that are pointing to my website’s IP address, but I dont know what else to check. What could be the problem?

Viewing 15 replies - 1 through 15 (of 26 total)
  • How new are they? Sometimes these things take a bit of time to propagate. Like an hour.

    oh… well that would have been really nice to know in the tutorial. yeah I installed MS and right after I just created the sub-domains. so i just created them, brand new, right out of the box.

    so how many hours would it take to propagate 6 sub-domains?

    It depends on the host 🙂 And sometimes on the whims of the kobolds in our machines.

    Normally it’s right away, but once in a while I have a site that takes a bit to catch up.

    However, you may also have wildcard wrong, since foobar.yourdomain.com should redirect you to a signup page: yourdomain.com//wp-signup.php?new=foobar

    then what is the proper way to assign a wildcard through cPanel?

    I have *.mydomain.com as the url…

    Also I have registration disabled since i am the only user at this point, no one else is working on this project.

    cPanel it’s create a subdomain *.yourdomain.com. And make sure that the subdomain’s Document Root is public_html.

    I hav e this issue to, on a local install. Except for sub directories NOT subdomains. I recently upgraded from WPMU to WP 3 and multisite all of my old blogs are working but new ones come up 403….. any ideas?

    oh, i was told to go to the DNS editor and add the domain there, should i do both places or just through “create a subdomain” ?

    wait is MU and MS the same thing?

    From Ipstenu:

    However, you may also have wildcard wrong, since foobar.yourdomain.com should redirect you to a signup page: yourdomain.com//wp-signup.php?new=foobar

    yeah it doesnt do that, instead it goes to yourdomain.com/wp-signup.php?new=yourdomain.com

    Also I tried removing the DNS wildcard and added the *.yourdomain.com subdomain via cPanel and it gave me that same result mentioned above, and it also jacked up my cPanel, so i had to remove it and it went back to normal. Do you think it’s because i have sub-domain entries in my DNS records? when cPanel was set-up it already had records like cpanel.yourdomain.com, mail.yourdomain.com, localhost.yourdomain.com, etc. if i were to delete those would that solve my problem?

    WPMU is the predecessor to WP Multisite (not the same thing, but close enough for horseshoes).

    Do you think it’s because i have sub-domain entries in my DNS records? when cPanel was set-up it already had records like cpanel.yourdomain.com, mail.yourdomain.com, localhost.yourdomain.com, etc. if i were to delete those would that solve my problem?

    No, don’t delete them!

    You made sure to point * at the public_html instance? I would ask your host if you can use wildcard subdomains at this point.

    You made sure to point * at the public_html instance? I would ask your host if you can use wildcard subdomains at this point.

    yes, * does point to /public_html, and nothing gets created, i checked via cPanel and Filezilla FTP.

    I double checked with my host, which is JaguarPC, i talked to their live support and they said that “mod_rewrite” is indeed installed and enabled. the only answer im waiting on from them is if my domain is mentioned in the mod_rewrite file.

    See I have a VPS server with one main domain that manages all my other domains, and this domain im working on is a managed domain, not the main domain. I think that might be the problem. I believe the mod_rewrite file only affects my main domain and nothing else. and JaguarPC couldnt answer that for me.

    I have tried to access the httpd.conf file but i dont have access to it. If I SSH, im in a jailshell…

    For now I deleted all but one of my sub-domain sites, and it’s been a couple hours now and it still hasnt become active. Would it be plausible to just add the sub-domain manually through cPanel and then add the sub-domain through wordpress?

    is their another step I might be missing? like do i need to re-upload another wordpress install or something like that?

    I’ve been having trouble setting up MultiSite on HostGator the past 2 days. I’m using Sub-domains and have my wildcard setup as *.mydomain.com. I have set up many multisite networks and don’t understand what is going on. It’s as if the .htaccess isn’t being read properly.

    The main site works fine and I can see that the site was created by clicking on Edit in the Sites section of the Network Admin. However, if I go to the site or I try to get to its dashboard, I get an Apache page that says congratulations, now you’re ready to add some files!

    What can I do?

    I’m going to try and do the sub-directory method instead and see if i can successfully create my network that way, if i do come out successful, then i know something is messed up with either my mod_rewrite or how i am adding a wildcard sub-domain.

    I have been told twice now that adding the sub-domain in the DNS records is the proper way ALONG with adding it via “Add a Subdomain” in cPanel. so apparently their is no proper tutorial on how to correctly install MS.

    Well, something is wrong, for sure, because every other time I set up a Multisite network, I did it according to the Codex instructions and had no problem. At about the same time as ChapDaddy, I successfully set up a sub-directory network, even though WP detected a previous install. Essentially, I have no clue WHY it worked, but thankful it has.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘can't access newly created sub-domains’ is closed to new replies.