Support » Fixing WordPress » can’t access my site

  • phamj95

    (@phamj95)


    I’m getting this when i try to access my website. I also tried to log in as admin but got the same error message

    Warning: require(/homepages/46/d422992150/htdocs/blog/wp-includes/link-template.php): failed to open stream: Permission denied in /homepages/46/d422992150/htdocs/blog/wp-settings.php on line 155

    Fatal error: require(): Failed opening required ‘/homepages/46/d422992150/htdocs/blog/wp-includes/link-template.php’ (include_path=’.:/usr/lib/php5.6′) in /homepages/46/d422992150/htdocs/blog/wp-settings.php on line 155

Viewing 7 replies - 1 through 7 (of 7 total)
  • Can you access the admin area? If so, have you tried to see if using a default theme such as Twenty Sixteen resolves this error? If it does, you will want to contact your theme’s developer.

    Also, if you have not already tried to disable the plugins by renaming the directory to plugins.hold you should try that to be sure that there is not a plugin that is causing the issue!

    Hope this helps. Do not hesitate to come back if it does not!

    phamj95

    (@phamj95)

    Hi Davood,

    i can’t even access the admin page.

    I also went and rename the plugins directory and still having the same issue.

    Thank You for your assistance

    Check to make sure the file that it cant open exists…. if it does exist be sure the permissions are set to at least 644 or 755

    If those those settings are all good you may want to consider posting a job over at WordPress Jobs and linking back to this thread. Due to the forum rules we can not take credentials and look at the problem first had; I am sure someone there can help you much faster than we can through the forum since you can provide them with credentials to go in and fix the problem for you.

    Before doing anything other than changing permissions I would advise backing the files and database up even though the site wont load so you can at least get the site back to where it is now should you decide to hire someone and they make the problem worse.

    phamj95

    (@phamj95)

    the file does exists but how do i find out where to change the permission?

    You should be able to change permission in your FTP program or through your hosts file manager if they provide one. Who are you hosted with? What FTP program do you use?

    I may be able to provide instructions for you depending who you are hosted with and/or what FTP program you use.

    phamj95

    (@phamj95)

    i use FileZilla and host with 1an1

    In filezilla you should be able to right click on the file and choose change permissions.

    On 1and1 are you using a cPanel hosting plan or do they give you a different hosting panel? I have never hosted with 1and1 so I am not sure.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘can’t access my site’ is closed to new replies.