Support » Fixing WordPress » Can’t access my page at all

  • Hi everyone!

    I’m really new to this so I apologize in advance for this whole thing.

    I’ve been running my page with no problems whatsoever until this morning when I accessed my self-hosted page through the mobile WordPress app. I added a new post draft and when I tried accessing my page on my desktop, it wouldn’t let me. I couldn’t access my wp-admin page nor the front end site, the error message being displayed was:

    “This site can’t be reached took too long to respond.

    Checking the connection
    Checking the proxy and the firewall
    Running Windows Network Diagnostics”

    From the diagnostics it says resource is online but not responding to connection attempts. I verified this on Is It Down? and indeed it is only down for me, which led me to assume it had something to do with my IP address, since I also can’t access the site through safari on my phone.

    If I turn on a vpn on my computer or phone, then I can access both my wp-admin page and the full front end site like I normally would.

    All this led me to believe that I was being IP blocked by Jetpack’s security features, so I logged in through and whitelisted my IP from there, and that didn’t seem to work. Without a VPN I still can’t access my site, back or front end, so something is blocking my IP from accessing my own site but I’m completely at a loss on what to do or how to fix it.

    Thank you in advance for your help.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • It looks like this site is using WP Super Cache:

    Cached page generated by WP-Super-Cache on 2020-01-15 10:44:41

    If you clear all caching created by the WP Super Cache plugin them temporarily disable the WP Super Cache plugin, does it work better then?

    Also, it looks like this site is hosted with Dreamhost, if that’s correct, do you know if mod_security is enabled?

    Thread Starter twoforksandapassport


    So right when I was trying to access the page again without a vpn to try and clear the cache, it loaded without a problem, so maybe the Jetpack whitelist changes took a while to take effect? I still cleared the cache to be sure.

    That’s correct, yes, and mod_security is enabled.

    Thanks for your quick response!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can’t access my page at all’ is closed to new replies.