Can't access http://localhost/mydatabase (11 posts)

  1. FernCreek
    Posted 4 years ago #

    I haven't been able to get WordPress to install locally for the first time.

    I have xampp running. I created a database 'ferncreek' in phpMyAdmin. I made sure that the user 'root' has all privileges. I modified the wp-config-sample.php file to show my database name, database username, and password (I also tried this with the password field blank) and saved it as wp-config.php.

    I went through the wp installation process, and it said that it couldn't access the database. I try to go to http://localhost/ferncreek/ and get a "page not found" error message.

    Am I overlooking something?

  2. Clayton James
    Posted 4 years ago #

    I'm a little confused by your title:


    It's not the database you need to access from your browser. It's the name of the folder you put wordpress in. If you copied your entire wordpress folder with all the files in it to the htdocs folder, then you would access wordpress with "http://localhost/wordpress"

    Or do you think you have a different issue? Root automatically has privileges on all databases by default with xampp. Is it possible that an error might have been made by unnecessarily adding or altering some root privileges?

  3. FernCreek
    Posted 4 years ago #

    All of the files are in c:\xampp\htdocs\mywordpress\

    I checked the privileges for root, and it does have full privileges.

  4. Sugar Apple
    Posted 4 years ago #

    it is better to install wordpress from the browser so you do not need to make a wp-config.

    just create a database and access your worpress folder (http://localhost/mywordpress).

  5. Clayton James
    Posted 4 years ago #


    How will that solve the "Unable to establish a connection to the database" error that FernCreek is having?

  6. martin coxon
    Posted 4 years ago #

    Hi Folks
    please accept my apoligies now. I am a newbie and having read lots of info and guidance im still not sure where to post my request for help so ive copied and pasted the problem/ warning I keep getting, its 9 lines long so im safe in that I dont have to go to pastebin.

    below is the body of text im getting as a warning,
    I would be most grateful for any help please even if its just sending me to the correct are of the forum to get this matter resolved

    Hair pulled out honest

    Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /homepages/15/d206099856/htdocs/www.phen375store.co/wordpress/wp-content/plugins/font/Font.php on line 96
    Warning: file_get_contents(http://fontsforweb.com/font/generatecss/?id=) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /homepages/15/d206099856/htdocs/www.phen375store.co/wordpress/wp-content/plugins/font/Font.php on line 96

    Thank you

  7. Clayton James
    Posted 4 years ago #

    @martin coxon

    See if anything in any of these conversations point you in the right direction: site:wordpress.org/support "URL file access is disabled in the server configuration" "no suitable wrapper could be found"

    While it looks like a plugin problem, a quick call to your hosts support group first, might rule out any actual server configuration issues.

    You may get more responses by starting your own new thread in the troubleshooting section. http://wordpress.org/support/forum/how-to-and-troubleshooting Hijacking a thread usually guarantees much less visibility of your issue to others.

  8. FernCreek
    Posted 4 years ago #

    Thanks for your help.
    However, when I try to go to http://localhost/mywordpress, what comes up is a blank page with "Error establishing a database connection."

  9. Clayton James
    Posted 4 years ago #

    The "from" permissions for root by default should be 'localhost' and '' That's one thing you can re-check. If those are correct, and root also has those permissions on your database, you should be able to connect with user "root" and whatever password you assigned to the root MySQL user when you ran the MySQL root user password setup at //localhost/security.

    If you can't, then you should re-verify that the root username, password, and database name info in wp-config are absolutely correct, including the single quote punctuation on either side of those entries.

    Something else you might try:

    Open phpMyAdmin and see if the user named "Any" exists. If so, completely delete that user, and then create a new user on your wordpress database and give that user full permissions for the wordpress database.

    Beyond that, I'm not sure what the issue could be.

  10. FernCreek
    Posted 4 years ago #

    Thanks. I did discover a typo in my naming of the database 'mywordpress' (yes, I'm embarrassed). I created a new database, properly spelled, and made sure that my wp-config.php referred to that database, and -- ta dah! -- it did work.

    Thank you for sticking with me on this!

  11. Clayton James
    Posted 4 years ago #

    No problem. I can't tell you how many times I've had to scour a page full of code for one little typo or forgotten character. It just happens once in a while. Glad you got it going!

Topic Closed

This topic has been closed to new replies.

About this Topic