Support » Fixing WordPress » can't access home page unless index.php is in url

  • delboy007

    (@delboy007)


    I have been messing around with my new blog a lot and now I can no longer get to my website using http://www.mysite/blog which worked before, I get a page not found error. Now I have to add index.php for it to work. Normally I would have said it was a problem on the server but I haven’t changed the server setting or any files on it

Viewing 8 replies - 1 through 8 (of 8 total)
  • esmi

    (@esmi)

    Did you change any of the urls in Settings->General? Did you set up any custom permalinks?

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Are you on a Windows server by any chance? That index.php glitch is something I often see with WordPress on Windows.

    Have you double-checked your .htaccess file to make sure nothing has changed?

    delboy007

    (@delboy007)

    two replies in 5 minutes. Is that a world record ?
    Yes I have setup custom permalink of /index.php/%postname%/.

    And yes I am on a windows server. After spending all day yesterday trying to get pretty links I discovered I can’t use a .htaccess anyway so I am using the almost pretty ones instead.

    If I go back to default permalink it is ok.

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    I don’t know if there is a way around the index.php problem on a Windows server, especially if your server isn’t running Apache and you cannot use .htaccess.

    There are a bunch of suggestions here you could look into, though the thread is a bit old:

    http://wordpress.org/support/topic/windows-server-using-permalinks-with-iis-no-apache?replies=18

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    delboy007

    (@delboy007)

    Excellent thanks. The problem is I have a web site and separate blog so I don’t want all error pages going to the same place. I have got around the problem with the simple solution of uploaded an index.htm in the root of my blog directory and the putting a simple html redirect in it.

    So I’m having the same problem with a WordPress site on a windows IIS server: under the default link settings, if you head to the main domain (http://www.mysite.com) it loads with an “index.php” added to the url (http://www.mysite.com/Index.php/). If I switch to a custom permalink structure, something like “/index.php/%category%/$postname%/”, then try to go to http://www.mysite.com, I get the dreaded 404 – just like delboy was saying, I need to add the “Index.php/” to the end to get to the homepage. Which is obviously not fantastic.

    Delboy’s idea of using a redirected html file certainly works, but I’m just wondering if anybody has either found a better solution or has some idea of the root of this problem.

    Figured out a slightly more robust solution. FYI: The site in reference here is on IIS6, which means fancy stuff like url rewrite won’t work.

    I’m using the static front page option described here:

    http://codex.wordpress.org/Creating_a_Static_Front_Page

    So I have a Page called “Home” I’m using for the Front Page.

    I then grabbed and activated this plugin here:

    http://wordpress.org/extend/plugins/permalink-editor/

    Then I went to my “Home” Page, and, using the new “Customise” button that the plugin added, edited the permalink to include “index.php/”. Everything works fabulously now, and I feel like it’s a touch more elegant than an HTML redirect.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘can't access home page unless index.php is in url’ is closed to new replies.