Support » Localhost Installs » Can’t Access existing localhost site

  • mateoco

    (@mateoco)


    Hi friends,

    So many things I need help with. Where to start?
    Ok so first last week I installed Xampp + WordPress and managed to open a localhost website. THAT TOOK ME ABOUT 8 HOURS to figure out.
    Yes, that kind of a NOOB.

    Even so, I managed to download a theme and generally started to get the hang of it. But today, when I wanted to get back where I stopped, I couldn’t access the site.
    1. Should there be an identifiable “wordpress icon” to click to get a quick access to the website?
    2. I guess not, so I enter Xampp, press “start” on both “apache” and “SQL” and press Admin, but get an unable to connect message.
    3. Tried to type “localhost:8080” and reached the “ApacheFriends” page but have no idea where to go next. Tried to type different “commands” but didn’t work.
    4. Only when I type localhost:8080/GlobalIdeology (which is the temporary name of the wordpress site) I get to an index page with a “wordpress” folder. When I press that one, I get that same “unable to connect” page.

    So I have opened a localhost website using Xampp + WordPress but now I dont know where the door is. Can you please help me?

    Thank you,
    M

Viewing 12 replies - 1 through 12 (of 12 total)
  • Little Package

    (@littlepackage)

    Are you sure Apache and SQL are both running? If they aren’t, try restarting the server. If XAMPP continues to give you trouble, seek help in XAMPP forums or by searching your particular error messages in Google.

    If servers are running, try localhost:8080/GlobalIdeology/wp-admin or localhost:8080/wp-admin

    Hey @mateoco,
    In XAMPP, by default, you don’t need at add :8080 after “localhost”, URL in your case should be http://localhost/GlobalIdeology.

    THAT TOOK ME ABOUT 8 HOURS to figure out. Yes, that kind of a NOOB.

    I suggest you uninstall XAMPP and follow the exact steps mentioned in the below article link for creating a local WordPress website:
    https://www.wpbeginner.com/wp-tutorials/how-to-create-a-local-wordpress-site-using-xampp/

    Thread Starter mateoco

    (@mateoco)

    Yes, it says they are both running. But writing what you suggest comes up as “404 not found” saying “Apache/2.4.46 (Win64) OpenSSL/1.1.1h PHP/7.4.12 Server at localhost Port 8080”. Can I attach a jpeg to show you?
    Also, how can I know if it’s XAMPP that’s responsible?
    Idealy, how this process should go? Is there a shortcut link to the wordpress website?

    Thank you so much for the quick reply.

    Thread Starter mateoco

    (@mateoco)

    Hi @prabhatrai!

    http://localhost/GlobalIdeology” brings me nowhere – “unable to connect” etc.

    I used the manual you linked to when installing XAMPP to begin with. I needed to add the :8080 because the default ports (80 and 443) where taken and I found that I can only start the Apache by changing the ports number.

    Also, if I uninstall XAMPP and go through the installing process all over again, wouldn’t I risk losing the website I already started?

    Hey @mateoco,
    You shall consider taking the backup of the website before uninstalling the server.

    Article on taking WordPress backup: https://wordpress.org/support/article/wordpress-backups/

    Little Package

    (@littlepackage)

    I only chimed in because I went through a similar problem with MAMP yesterday, and the solution was found by Googling the error message. I hesitate to have you re-build the whole thing when my solution was easily found and involved clicking a button. Saved me a LOT of time.

    A very simple and easy test of a WordPress site is to try and load the “readme.html” file. Being able to view it validates that the webserver configuration has the correct directory mapped and that the files are readable. Without having this correct it is a hopeless task with many more questions than answers. Once you have established that the correct directory is being accessed by the webserver, then it is a good time to start asking questions about PHP servers and databases etc.

    Thread Starter mateoco

    (@mateoco)

    Hi guys,

    Wanted to let you know the problem was with the XAMPP port settings in myphpadmin. I reached out to XAMPP community forum and the great moderator over there helped me fix it. Now I can get back on building my site! Thank you for reccomneding me to post my questions over there aswell.

    Thread Starter mateoco

    (@mateoco)

    Hi guys,

    Just a quick followup: Now that I regained access to the localhost site, how do I get back to editing and designing it? I know it’s sounds like the simplest of questions but I just don’t understand how to do that…

    Thanks,
    M

    @mateoco As the only lady here (not a “guy”) who suggested you chat with XAMPP folks rather than nuking your setup, I’ll take a quick bow. Very glad you got a relatively painless fix.

    You can see the front end of your website on your local setup? Why not go to /wp-admin or /wp-login.php, log in, and begin editing?

    Thread Starter mateoco

    (@mateoco)

    @littlepackage My bad my bad. Sincere apologies. Next time I’ll use “fellas”. 🙂 Perhaps you can help me with my other noobish question, as to how do I get back at editing the site?

    The answer is quite simple if you follow these steps in right way you can sort out your problem.

    Press the Windows key.
    Type Notepad in the search field.
    In the search results, right-click Notepad and select Run as administrator.
    From Notepad, open the following file: c:\Windows\System32\Drivers\etc\hosts.
    Make the necessary changes to the file.
    Select File > Save to save your changes.

    I hope it will helpful for you.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.