WordPress.org

Support

Support » Plugins and Hacks » Dropbox Photo Sideloader » [Resolved] Can't Access Dropbox Sub-Directories

[Resolved] Can't Access Dropbox Sub-Directories

Viewing 7 replies - 1 through 7 (of 7 total)
  • Go back and create the App on Dropbox properly, making sure that you give it full access. The plugin will not work with any form of partial access.

    Hmm. I did that before I reposted to a new forum. I tried it again however, and still “no joy.” I get no response when I click on a folder. Here’s how I created my Dropbox App:

    1. Chose Dropbox API app (rather than Drop-ins app)
    2. Selected “Files and Datastores” rather than “Datastores only”
    3. Answered “No” to “Can your app be limited to its own folder?”
    4. Chose “All file types” over “Specific file type” for app access
    5. Named the app “chiefApp_2”

    The “Settings” are:

    Status: Development
    Development users: Only you
    Permission type: Full dropbox

    OAuth2
    Redirect URLs: Blank
    Allow implicit grant: Allow
    Generated access token: Generate

    Drop-ins domains: Blank
    Webhook URLs: Blank

    Also, I tried Firefox, IE, and Chrome with no success. Could there be an issue with the latest version of WP?

    Any other ideas?

    Thanx!

    hb

    No, it works fine with 3.9.1. Just tested it.

    Did you expand the folder by clicking on the plus sign to the left of it?

    There is no plus sign…

    There is a line for each folder, with a checkbox and then the folder name as a link. Here is how it looks, using “[]” for a checkbox:

    []_/administrative
    []_/boardMeetingMinutes
    []_/boardOfDirectors
    []_/buildingPlanning

    Each folder name is underlined, starting with an underlined blank space immediately after the check box, then the “/” character.

    As an example, the link for the “administrative” folder is:

    http://184.154.224.16/~chief731/wp-admin/media-upload.php?chromeless=1&post_id=502&tab=dbsideloadphotos#

    In fact, click this link to see what the folder list actually looks like!! 🙂

    Hope this helps.

    hb

    Otto,

    I’m using the Cherry Framework and a Cherry theme, if that might be the issue…

    hb

    No idea on whether or not your theme is the problem, but if you’re not seeing the expandable directory tree, then you’re likely not getting the Javascript loading. Check the browser console for errors, try disabling plugins, switching to default theme, etc. Find what’s causing the conflict.

    Weird!

    I just tried it for the first time in two days, and the plugin asked for my App key and secret, and then gave me the complete folder list. Everything is fine now…but I have no idea why!!

    hb

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Can't Access Dropbox Sub-Directories’ is closed to new replies.
Skip to toolbar