Support » Fixing WordPress » Can't access dashboard (wp-admin) after upgrading to 3.9

  • Resolved Bicho

    (@bicho)


    Hi. I upgraded to WP 3.9 a couple days ago and now I can’t access the dashboard (wp-admin). All I see is a blank space and the message:

    Fatal error: Cannot redeclare _relocate_children() (previously declared in /home/USER/mydomain.com/wp-admin/includes/post.php:863) in /home/USER/mydomain.com/wp-admin/includes/deprecated.php on line 1190

    I’m not 100% sure the issue is related to the upgrade, but after looking at recent forums I see a lot of people having problems with 3.9

    I have 3 WP sites under the same domain. They’re working fine, but I can’t access (wp-admin) any of them.

    I tried resetting plugins. Didn’t work.

    Does anyone have a clue on this? Any help would be much appreciated.
    my site: http://www.grafiscopio.com

Viewing 15 replies - 1 through 15 (of 20 total)
  • Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    Please start by giving the 3.9 Master List a read.

    https://wordpress.org/support/topic/wordpress-39-master-list?replies=6

    I tried resetting plugins. Didn’t work.

    Just incase it’s something missing can you please try a manual update?

    http://codex.wordpress.org/Updating_WordPress#Manual_Update

    I have exactly the same problem, I was going to try a manual update but how do i deactivate plugins when I cant access the admin panel????

    Thanks, Jan. I’ll read the link you suggest.

    chrisroberts37: you can deactivate plugins via phpMyAdmin or FTP. Here’s how.

    Bump. Having the same problem. My database is always automatically updated by Dreamhost and I received an email saying the update was successful. I’m locked out of my dashboard. My fatal error message is the same… problem with line 1190. WP, please advise as there is a lot of us with the same problem.

    rhicoverasmile:

    My database is always automatically updated by Dreamhost and I received an email saying the update was successful.

    Same here. Same hosting provider. I just sent Support an email reporting this issue. Let’s see what happens. In the meantime I suggest we take a look at Jan Dembowski‘s links. Maybe we can figure it out ourselves.

    Hi all, I managed to cure mine, I did the manual update as per the link above, I used an FTP client to upload the files, to disable the plugins, just rename the plugin folder inside the wp_content folder to plugin.old, then do the update as described in the above link, after you complete the update just rename the plugin folder back to what it was. You should be able to login again. You may get an option to update your database when you log in, if so, just follow the onscreen prompts.

    I’m having the same problem.

    Anyone know if this will get fixed before I have to go into all the backdoor stuff and possibly F up my website?

    AI1EC_PATH . DIRECTORY_SEPARATOR . ‘lib’ . DIRECTORY_SEPARATOR . ‘strategy’ . DIRECTORY_SEPARATOR . ‘class-ai1ec-persistence-context.php’, ), ), ‘Ai1ec_Platform_Controller’ => array ( 0 => array ( 0 => ‘0’, 1 => AI1EC_PATH . DIRECTORY_SEPARATOR . ‘app’ . DIRECTORY_SEPARATOR . ‘controller’ . DIRECTORY_SEPARATOR . ‘class-ai1ec-platform-controller.php’, ), ), ‘Ai1ec_Platform_Helper’ => array ( 0 => array ( 0 => ‘0’, 1 => AI1EC_PATH . DIRECTORY_SEPARATOR . ‘app’ . DIRECTORY_SEPARATOR . ‘helper’ . DIRECTORY_SEPARATOR . ‘class-ai1ec-platform-helper.php’, ), ), ‘Ai1ec_Renderable’ => array ( 0 => array ( 0 => ‘0’, 1 => AI1EC_PATH . DIRECTORY_SEPARATOR . ‘lib’ . DIRECTORY_SEPARATOR . ‘interface’ . DIRECTORY_SEPARATOR . ‘class-ai1ec-renderable.php’, ), ), ‘Ai1ec_Requirejs_Controller’ => array ( 0 => array ( 0 => ‘0’, 1 => AI1EC_PATH . DIRECTORY_SEPARATOR . ‘app’ . DIRECTORY_SEPARATOR . ‘controller’ . DIRECTORY_SEPARATOR . ‘class-ai1ec-requirejs-controller.php’, ), ), ‘Ai1ec_Router’ => array ( 0 => array ( 0 => ‘0’, 1 => AI1EC_PATH.

    I have the same issue. I have already renamed my plug-ins but still not working.

    pronamel81: I’m waiting for an answer from my hosting provider, hopefully tomorrow. I could try WP manual update but I’m saving that for the worst case scenario. I don’t want to F up my site either.

    I’m also waiting for my host if there’s a work around.

    as well as changing the plugin dir name to disable the plugins, you also need to do the manual update as described in the above link

    Look, don’t bother waiting around. Make a backup of your site’s files, then do a manual update.

    This message:

    Fatal error: Cannot redeclare _relocate_children() (previously declared in /home/USER/mydomain.com/wp-admin/includes/post.php:863) in /home/USER/mydomain.com/wp-admin/includes/deprecated.php on line 1190

    That means that your site is only partially updated. Not all the site’s files have been upgraded. The only solution is a manual update, update all the WordPress files on the site.

    There is no other fix possible here. You need to manually update the site. Nobody else can do it for you.

    @kenfox101: Your error message is different, please start your own thread.

    Thank you Samuel, but I’m paying my hosting provider to do so. If they send me a mail with this subject: “success upgrading WP on your site!” then I expect that. Which brings up a 2nd question: Would I need to manually fix this everytime there’s a new version of WP..?

    You shouldn’t need to manually fix it. That would not happen with a normal upgrade.

    But if that’s the error you’re getting, then the problem is that the upgrade is incomplete. Only some files were upgraded, not all the files. I have no idea how, or why this would occur, but the error message is pretty clear.

    ALL the WordPress files need to be updated. Doing a manual update will do that. It takes about 5 minutes. That seems to me to be a simpler solution than waiting around for days expecting somebody else to fix it for you.

    Thanks once again Samuel. I was about to do it myself when my host sent this message: “I have reinstalled the core WP files for your domains and the sites appear to be loading without issue now”.

    That’s about it. Problem solved.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Can't access dashboard (wp-admin) after upgrading to 3.9’ is closed to new replies.