WordPress.org

Support

Support » How-To and Troubleshooting » Can’t access dashboard; getting two errors

Can’t access dashboard; getting two errors

  • I can’t get to my WP dashboard and could use some advice. I get the following two messages upon login:

    Warning: require_once(ABSPATHwp-admin/includes/dashboard.php) [function.require-once]: failed to open stream: No such file or directory in /home/sgerbig/stephtalkscontent.com/wp-admin/index.php on line 13

    Fatal error: require_once() [function.require]: Failed opening required ‘ABSPATHwp-admin/includes/dashboard.php’ (include_path=’.:/usr/local/lib/php:/usr/local/php5/lib/pear’) in /home/sgerbig/stephtalkscontent.com/wp-admin/index.php on line 13

    Here’s what I did to try to fix it:
    1. I uploaded a new dashboard.php and wp-admin/index.php.
    2. I checked the chmod for those files.
    3. I reinstalled WP.

    Didn’t make a difference.

    Until today, everything’s been working really well. However, this is the first time I’ve tried to access the dashboard since the automatic WP update a few days ago. Not sure if the two are related.

    Got any ideas? Thanks in advance.

Viewing 9 replies - 1 through 9 (of 9 total)
  • This was an old issue but not sure what the cause was. Think it was a server problem with the ABSPATH vaiable.
    If you look at line 13 in /wp-admin/index.php you should see the line its choking on:
    Warning: require_once(ABSPATHwp-admin/includes/dashboard.php)

    Change the section to a variable path like.
    require_once(‘./includes/dashboard.php’)

    Just until you can see why the server does not like the variable.

    Thanks for helping, webjunk!

    I made the change you suggested above and now I’m getting this error:

    Fatal error: Call to undefined function get_option() in /home/sgerbig/stephtalkscontent.com/wp-admin/includes/dashboard.php on line 21

    Line 21 of includes/dashboard.php reads:
    $widget_options = get_option( ‘dashboard_widget_options’ );

    Any advice with this one?

    Not sure. Try disabling plugins and see if that works. Also try the default theme as it could cause this too.

    Just got the exact same problems. But it’s a clean start for at new domain that never has used WP. At http://www.web10.dk I had to use their easy-installation-box but they only offer ver. 2.7.
    After that (no plugins, themes etc.) i used the autoupgrade in WP and after waiting 10-15 minutes the site shows itself again and the maintenance screen disappears. Only trying to login to the dashboard results in exactly the same error-messages as described above.

    I’ve tried a lot of things, but somehow version 3.0.1 gives me trouble.
    After advice in the danish support forum I tried using version 3.0. Cleared out the server and db. Then waited overnight. Made a ftp-upload and voila – the 5 minutes installation took only 2 minutes.

    Just had the same problem following an upgrade from 3.0.0 to 3.0.1.

    bjmoney

    @bjmoney

    I have the same problem in my site. Can anyone help us to solve this? Thanks!

    Same here, but I’m with 2.9.2.

    Same exact errors:

    ABSPATH is never defined and then if I define it, I get the get_option() function undefined.

    Anyone figure this out?

    Some Testing:

    <?php
    $included_files = get_included_files();
    echo '<pre>';
    print_r($included_files);
    echo '<pre>';
    ?>

    The Output:
    Array
    (
    [0] => /home/somepath/public_html/blog/wp-admin/index.php
    [1] => /home/somepath/public_html/blog/wp-admin/admin.php
    )

    This shows wp-load.php is never loaded.

    Found my issue

    ABSPATH is defined in /wp-admin/admin.php so that is the most obvious place to look for an error.

    In my case, this file existed but was empty. I’m guessing it was the result of a file transfer error during the last upgrade.

    My Solution:
    Download a copy of wordpress that matches your version number. Replace the /wp-admin/ with the one from your fresh install version.

    The version repository can be found here: http://wordpress.org/download/release-archive/

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can’t access dashboard; getting two errors’ is closed to new replies.