WordPress.org

Forums

[resolved] Can't access dashboard: getting SSL error message (21 posts)

  1. catherinelloydevans
    Member
    Posted 2 years ago #

    Hi all,

    I cannot access my site.
    My last action was one of the actions suggested in the Yoast SEO plugin tutorial on making SEO improvements on your site.
    As instructed in the tutorial, I was changing the URLs in Settings-General WordPress Address and Site address. I removed the /wp and clicked Save Changes, but the result was an Error 404 page.
    I used the Back function and attempted to rewrite the /wp thinking it had not wanted to accept this, but again got an Error 404 message.
    I then attempted to log out and log in again, and am now receiving the following message when I go to
    http://www.communications.com/wp/wp-admin and attempt to login using my username and password.
    I am unable to log in when I go to generic wordpress login screens too.

    "Secure Connection Failed
    An error occurred during a connection to redkitecommunications.com
    SSL received a record that exceeded the maximum permissible length
    (Error code: ssl_error_rx_record_too_long)
    *The page you are trying to view cannot be shown because the authenticity of the received data could not be verified
    *Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site."

    FYI: My site is hosted (I think, although I'm not clear on domains/subdomains etc) as a subdomain within another domain at my hosting company if this is relevant.
    I am using a Mac and Firefox.
    I am able to log in ok to the other sites I have.
    My site will appear as 'under construction' at http://www.redkitecommunications.com because I installed a plugin to show that while I build it ready for launch.

    Did I somehow 'break' my site?!

    I have no idea how to fix this or where to proceed from here, so any help would be gratefully received. Many thanks,
    Catherine

  2. keesiemeijer
    moderator
    Posted 2 years ago #

    Try setting the urls back with one of these methods:
    http://codex.wordpress.org/Changing_The_Site_URL

  3. catherinelloydevans
    Member
    Posted 2 years ago #

    Ok, thank you.
    My file/coding skills are very shaky and I want to make sure I don't do anything stupid - heeding the warnings of those who rightfully say 'don't change the code unless you know what you are doing!' so, with that in mind:

    1) Do you think the errors occurred because I changed the URLs then? ie that needs to be fixed? Slightly worrying that this is in a tutorial for the plugin...!
    2) Pardon the basic level of my question, but in the tutorial you've linked to - where do I do this change to the wp-config.php file? In the CPanel of my host, yes?
    3) If I can't then ever change that, as it says in the tutorial, will that affect my SEO rankings? ie, if the site URL has /wp after it?

    Thanks so much for your prompt reply, I'll wait to hear back before I make any changes, just to be on the safe side.

    Catherine :-)

  4. keesiemeijer
    moderator
    Posted 2 years ago #

    1) Do you think the errors occurred because I changed the URLs then? ie that needs to be fixed?

    Yes.

    Slightly worrying that this is in a tutorial for the plugin...!

    For moving your WordPress install to the root of your domain try
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory.

    2) Pardon the basic level of my question, but in the tutorial you've linked to - where do I do this change to the wp-config.php file? In the CPanel of my host, yes?

    Yes, with the Cpanel file manager or by using FTP.

    3) If I can't then ever change that, as it says in the tutorial, will that affect my SEO rankings? ie, if the site URL has /wp after it?

    I don't think "wp" in the url will affect your SEO, but if you change your url (move your site) you need to re-direct the old urls with "wp" in them to their new location with a plugin or by editing your .htaccess file
    http://wordpress.org/extend/plugins/redirection/

    Do you have a link to the Yoast SEO plugin tutorial?

  5. catherinelloydevans
    Member
    Posted 2 years ago #

    Thank you so much - that is great.
    Ok, so - when I add the pieces of code below to the wp-config.php file

    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

    from the WP tutorial, I literally paste them to the bottom of the code in the file?
    ie this would be on lines 91 and 92 of the existing file - does that sound right?
    Obviously ensuring I use http://redkitecommunications.com instead of example.com

    A link to the tutorial: http://yoast.com/articles/wordpress-seo/#www-non-www

  6. catherinelloydevans
    Member
    Posted 2 years ago #

    :-(
    I've tried adding that code to the file, but no change.

    I'm still getting an error 404 message when I try to log in using this login address
    http://redkitecommunications.com/wp/wp-admin/
    which is what I was using to access my site before...

  7. catherinelloydevans
    Member
    Posted 2 years ago #

    :-(
    I've tried adding that code to the file, but no change. I changed it back just so I don't do any other damage!

    I still got an error 404 message when I tried to log in using this login address
    http://redkitecommunications.com/wp/wp-admin/
    which is what I was using to access my site.

    There are two wp-config.php files in my directory. My primary domain is aruleoft (remember I said redkitecommunications is a subdomain)
    To break down the structure then, there are:

    home/aruleft
    - public_html
    - - wp-config.php

    and there is also

    home/aruleft
    - www
    - - wp-config.php

    where I've used - to show the hierarchy (sorry, not sure of the correct ways of writing these things down!)

    Both public_html and www have folders entitled cgi-bin, redkitecommunications, wp-admin, wp-content and wp-includes before then listing lots of php and other files.

    So I'm not sure which to edit?

  8. keesiemeijer
    moderator
    Posted 2 years ago #

    Did you put this in your wp-config.php?

    define('WP_HOME','http://redkitecommunications.com/wp');
    define('WP_SITEURL','http://redkitecommunications.com/wp');

    put it just before:

    /* That's all, stop editing! Happy blogging. */
  9. catherinelloydevans
    Member
    Posted 2 years ago #

    Ok, thank you, I've made that change to the wp_config.php file.

    I've just attempted to log in using
    http://redkitecommunications.com/wp/wp-admin/

    but no joy....

    I've checked all the various domains (ie when I open my File Manager it gives lots of options of which directory to open - home, www, public_html etc etc) and all wp_config.php files related to redkite now contain that change.

    Any ideas?
    And thank you so much for taking the time to help me with this, I very much appreciate your efforts.

  10. keesiemeijer
    moderator
    Posted 2 years ago #

    My site will appear as 'under construction' at http://www.redkitecommunications.com because I installed a plugin to show that while I build it ready for launch.

    What plugin are you using?

    try:

    - resetting the plugins folder by using FTP or whatever file management application your host provides. Sometimes, an apparently inactive plugin can still cause problems.

    - switching to the default theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides.

  11. catherinelloydevans
    Member
    Posted 2 years ago #

    Ok, tried the resetting the plugins folder using the renaming method.
    No joy ;-(

    I'll try your advice of switching to the default theme. I think I'm using twentyeleven at the moment - what should I rename the twentyeleven folder to??

    I notice on the same tutorial as the resetting plugins post, there is this advice (pasted below). Do you think I should be pursuing this?? I think in this case I need the help of my host! That sounds like something I could easily mess up...

    "How to fix 404 error when using Pretty Permalinks?

    If an error 404 occurs when using the Pretty Permalink choices such as Day and Name in Administration > Settings > Permalinks it could be a result of the mod_rewrite module not being activated/installed. The solution is to activate mod_rewrite for the Apache web-server. Check the apache\conf\httpd.conf file for the line `# LoadModule rewrite_module modules/mod_rewrite.so and delete the # in front of the line. Then stop Apache and start it again. Note: you may have to ask your host to activate mod_rewrite. "

  12. keesiemeijer
    moderator
    Posted 2 years ago #

    Don't rename twentyeleven, it is the default theme.

    WordPress still thinks the site is in: http://redkitecommunications.com/ (without the wp) so I think you're not editing the correct wp-config.php. Remove the lines from your wp-config.php and try it with the functions.php method: http://codex.wordpress.org/Changing_The_Site_URL#Edit_functions.php

    mod_rewrite is activated If pretty permalinks worked before.

    What does http://www.communications.com/ have to do with all this?

  13. catherinelloydevans
    Member
    Posted 2 years ago #

    Ok, I'll try that.

    Not sure what you mean -
    What does http://www.communications.com/ have to do with all this?
    -

    If I wrote that it's a typo - meant to be redkitecommunications.

  14. catherinelloydevans
    Member
    Posted 2 years ago #

    No joy with the functions.php edit either!

    I'll doublecheck the wp-config.php files - when I checked, the changes had been made to all the wp-config.php files I could find (remember I mentioned those files exist under both www and public_html.

    But I'll doublecheck again!

  15. catherinelloydevans
    Member
    Posted 2 years ago #

    I'M IN!

    My eyes are nearly falling out from scouring every file in my File Manager, and looking in every domain I could find. When I go to File Manager it asks which domain I want and there are several different roots, ie aruloft/redkitecommunications, redkitecommunications and aruleoft etc
    So I went through everything with a fine-tooth comb.

    And at last, I'm back in!

    Not a mistake I'll be making again, and I think I may uninstall that Yoast plugin now, too, in case I accidentally do anything else that dramatically affects my site.

    I'm so grateful to you for your patience, thank you very much indeed. :-)

  16. keesiemeijer
    moderator
    Posted 2 years ago #

    You're welcome. I'm glad you got it resolved :-)

  17. catherinelloydevans
    Member
    Posted 2 years ago #

    Me too! ;-)

  18. mksandy
    Member
    Posted 2 years ago #

    hey...can help me to access my dashboard....they create this error

    The site's security certificate is not trusted!
    You attempted to reach davcriz.com, but the server presented a certificate issued by an entity that is not trusted by your computer's operating system. This may mean that the server has generated its own security credentials, which Google Chrome cannot rely on for identity information, or an attacker may be trying to intercept your communications. You should not proceed, especially if you have never seen this warning before for this site.

  19. esmi
    Forum Moderator
    Posted 2 years ago #

    @mksandy: As per the Forum Welcome, please post your own topic. Your problem - despite any similarity in symptoms - is likely to be completely different.

  20. mksandy
    Member
    Posted 2 years ago #

    then what i do???? help me ....give me some advise bro....

  21. catherinelloydevans
    Member
    Posted 2 years ago #

    Hi again!

    I've now launched my site, and rather than open a completely new query - I thought I'd tag on to this one because this history is pretty relevant to my next request!

    I now have a pretty ugly URL of http://www.redkitecommunicaions.com/wp, which is what I'm having to direct people to. Obviously I'd like to remove the /wp, but I'm terrified of doing this.

    Which wordpress help article do you think will best enable me to do this, given my history of problems with my root directory??

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic