Support » Plugin: Very Simple Event List » Can’t Access Custom Fields

  • When I try to display custom fields in the editor by clicking the three-dots icon, then “Options”, then checking off the box for “Custom Fields”, the page refreshes and the Custom Fields editor section is not there. When I go back into the menu, I can see that the “Custom Fields” checkbox is un-checked again. I don’t have this issue on Posts or Pages, just Events.

    Using wordpress v5.2.1 with no other plugins active.

    How can I view the Custom Fields in the editor?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Guido

    (@guido07111975)

    Hi Kay,

    The extra fields should always be present, please check this pic. So it’s not a block.

    Guido

    Hi Guido. I use the super simple plugin that you have developed. It is really simple. However, I have a problem of customizing the fields when I edit an event. I want to add new fields after location field: For example, PRICE field, ASSOCIATION field. I tried with the plugin add costom field without success.
    I would be very happy if you can help me solve this problem.
    Thank you Guido

    • This reply was modified 1 year, 8 months ago by steph2019.
    Plugin Author Guido

    (@guido07111975)

    Hi,

    You can easily add extra fields by creating a new ACF Field Group, those fields will be listed similar to the “default” event fields in the create/edit event page in dashboard.

    But in order to display them in the frontend of the event list as well, you should change my plugin file “vsel-list”.

    Example, if you want to add a field with label Price you can add something like this:

    
    $field_1 = get_field('your-field-key');
    $output .= '<p>';
    $output .= sprintf(__( 'Price: %s' ), $field_1);
    $output .= '</p>';
    

    Guido

    Thank you for your answer Guido. I opened the file but I do not know exactly which line to insert the code. I think line 68 but i’m not sure. Can you help me please?

    By creating the Price field with Advanced custom fied, I gave an id. What I miss is after which line insert the code that you wrote

    Steph

    • This reply was modified 1 year, 8 months ago by steph2019.
    Plugin Author Guido

    (@guido07111975)

    Hi Steph,

    If you want it underneath Location, you should add the code at line 56 and further.

    So above if ( ($page_link_hide != 'yes') ) {

    (if you don’t see the field key while creating ACF fields, make it visible via the Screen Options tab)

    Do you link each event to its single event page as well? In that case file “vsel-templates” should be adjusted as well.

    Guido

    Hi Guido.

    Thank you very much for your answer. I will try it.

    Yes i link each event to its singles event page as well.

    Steph

    Plugin Author Guido

    (@guido07111975)

    Hi,

    In that case open file “vsel-templates” as well and add this underneath string 45:

    
    $field_1 = get_field('your-field-key');
    $price .= '<p>';
    $price .= sprintf(__( 'Price: %s' ), $field_1);
    $price .= '</p>';
    

    And look for string 60 (string starts with $content =) and add this after $location:

    
    . $price
    

    And to avoid an undefined index warning add this underneath string 10:

    
    // initialize extra fields
    $price = '';
    

    And of course repeat this process for the other ACF fields..

    But to be honest, I don’t recommend changing plugin files directly but there’s no other way to do this.

    Guido

    • This reply was modified 1 year, 8 months ago by Guido. Reason: Have updated my reply

    Hi Guido

    I admit the method you described is clear to me. Thank you for spending a little of your precious time. I liked your readiness to answer.

    I wanted to ask if the changes will not be lost once the plugin is updated. Fortunately you mentioned it.

    I want to ask you for a service. Please, If you can make that in the next version, you give the users the possibility to directly add some additional fields, without using add costum fied, that would be great. It is a complaint that I formulate.

    Thank you

    Steph

    Hi Guido
    I would really like it because I just need these few extra fields and it would be perfect for me. Thank you for thinking of my request.

    Thank you

    Steph

    Plugin Author Guido

    (@guido07111975)

    Hi Steph,

    It’s not that easy to include this feature because not every users wants the same field order.. so I should make hooks above/underneath every current field, so the ACF custom fields can be added everywhere. Drag-and-drop will be the nicest solution.

    Guido

    Hi Guido
    Oh super guido!

    It’s really great what you propose as a solution. I find it ideal. it allows each user to drag and drop the fields he created with the ACF plugin.

    Thank you Guido. I am too happy for your readiness to answer.
    it would be nice for me that in a few days, you can have a little time to add this hook as you said.

    thank you

    Steph

    Plugin Author Guido

    (@guido07111975)

    Hi,

    It definitely will not be added within a few days, because it’s a lot of work and this plugin is a hobby project for me. Besides this, I have to find out how to do this.

    Guido

    Hi Guido
    Thank you Guido for your answer. you are right. You have to really find out how to do it and especially that it takes time to do it. I cross my fingers hoping that you find the solution soon.

    for now I’m happy with these fields available for the plugin while hoping you find the right solution. Thank you Guido. Sincerely;

    Thank you

    Steph

    • This reply was modified 1 year, 8 months ago by steph2019.

    Hello Guido,

    Just going back to my original question:
    I am asking about the built-in WordPress “Custom Fields” section (described here: https://wordpress.org/support/article/custom-fields/), not the custom fields you have added with the plugin. I ask because I am using another plugin that imports data into the “Custom Fields” section, but I am unable to access it. I think this is a bug?

    Plugin Author Guido

    (@guido07111975)

    Hi Kay,

    Sorry your thread got sort of hijacked.. 😉

    I understand you now.

    My plugin does not support this, while registering the “event” post type.
    Apparently the new editor is not very clear. When using the Classic Editor, you don’t see the custom fields checkbox when clicking the Screen Options tab. More clear.

    If you want to support this, you should make a change in file “vsel”. Look for string 118 and add this after 'editor':

    , 'custom-fields'

    But this has no visible effect in the frontend of your site yet.

    Guido

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Can’t Access Custom Fields’ is closed to new replies.