[resolved] Can't access admin area as Administrator, but I can as an Editor (2 posts)

  1. Z-247
    Posted 3 years ago #

    Hi, I've just tried to log into a site in development as my administrator account, and was left sitting at the login screen for ages. No errors, just the spinning circle of the the browser working.

    However, if I go to another page, I am actually logged in, and can see things like the 'edit this post' links. Clicking those links just leads to a 404 error though. I can't actually get into the admin backend area.

    I then tried to sign in as an editor account, and was able to do so. I could see the admin area fine. So at least it's not gone altogether, right?

    I've tried clearing cookies and switching browsers, which didn't help.

    I've checked file permissions via FTP, and wp-admin and wp-includes are currently all 755.

    I even tried changing wp-db.php in wp-includes, in order to set the query timeout to 600, but it didn't make a difference.

    I've disabled all my plugins via FTP, which didn't seem to help. I also noticed in my wp-admin directory that I had an error log with a lot of "WordPress database error MySQL server has gone away for query SELECT..."

    I was just looking at phpMyAdmin, but I wasn't sure what to look for there. I did notice a message about the MySQL server has only been running since yesterday. Could this have broken things? If so, anyone have an idea as to what, and then how to fix it?

    Thanks for any help!

  2. Z-247
    Posted 3 years ago #

    Well, it appears that it was a problem with the server. It's 'coming back' for the most part now after my hosts have been working on it. If I ever get more details, I'll try to share them for posterity.

Topic Closed

This topic has been closed to new replies.

About this Topic