Support » Installing WordPress » Can’t access Admin

  • page1929

    (@page1929)


    I did the upgrade to 2.5 and now I cannot access wp-admin??? HELP!

Viewing 15 replies - 1 through 15 (of 17 total)
  • page1929

    (@page1929)

    ok so I went back to my webhost and reverted back to the old version of WP and now I can get in again. Not on 2.5, but at least I am functional.

    I think I am going to wait until all your kinks are worked out. Reading this thread does not offer me any confidence in upgrading especially since some of the posters have requested help over an hour ago and they are still waiting…..

    tgiokdi

    (@tgiokdi)

    This thread is just you posting, lol

    somebaudy

    (@somebaudy)

    same here : I have access to [my blog]/wp-admin/post-new.php but

    [my blog]/wp-admin/index.php is a blank…

    fwiw I used the InstantUpgrade plugin.

    herdoftravis

    (@herdoftravis)

    Same problem here… upload 2.5 file and it broke, reverted to 2.3.3, now I can’t login with admin.

    Not good

    whooami

    (@whooami)

    Member

    If you have an index.php inside wp-content/plugins/ delete it. Use an index.html instead.

    herdoftravis

    (@herdoftravis)

    I don’t have index.php nor index.html inside wp-content/plugins. I do have an index.php inside wp-content; it’s the one that says silence is golden.

    whooami

    (@whooami)

    Member

    hmm, ok, just an idea.

    herdoftravis

    (@herdoftravis)

    thanks, I appreciate it whooami 🙂

    gorik

    (@gorik)

    I can’t access my dashboard either. You can get to your admin page by clicking ‘Edit’ on one of your posts (if you have the option). I can access all my admin pages, except for the dashboard.

    therivits

    (@therivits)

    This is way too complicated and not necessary….see U

    KungFuQuip

    (@kungfuquip)

    You didn’t read the upgrade instructions carefully enough. Specifically, you must delete the wp-admin and wp-includes folders completely before you FTP your files over.

    Since you have already done your upgrade, you can delete the folders and reload the new versions and you should be fine.

    akiwitz

    (@akiwitz)

    I did delete the includes and admin folder before upgrading, i get the error anyway 🙁

    Here is a solution, however i seem to have another k2 installation and it doesn’t help me either…
    K2 + WordPress 2.5 = Broken? I Can Fix That

    whooami

    (@whooami)

    Member

    its a plugin, most likely .. demonstrated by the fact that NOT EVERYONE has this problem.. and rather than wave goodbye (therivits) you would be better off to systematically delete plugins until you can get in.

    you can delete 3 at a time with an ftp client, try the wp-admin/index.php page..

    just a little troubleshooting..

    herdoftravis

    (@herdoftravis)

    therivits, I know what you mean…

    (1) This problem occurred on my wife’s blog. On mine it upgraded flawlessly (even without deleting folders first).

    (2) I did delete the folders, several times, after the issue started occuring. I deleted all folders/files, uploaded v2.5 and the same error that started this problem occurred. The app couldn’t find the Server(“PATH_INFO”) property and error’ed out on lines 72 and 75 of the wp-settings.php script. I deleted all folders/files again and uploaded v2.3.3 and that’s when I couldn’t get into my Admin account, though all my content was there. I even tried both methods (delete–>v2.5 and delete–>2.3.3) twice with the same results.

    (3) The root cause, I believe, is that there’s a server configuration conflict with my host regarding the PATH_INFO variable. Subsequently, this cause the wp website to not load right, and then the database to not update right.

    (4) Solution (yes, this was way too complicated): (a) I deleted all files and uploaded v2.3.3 since v2.5 was just not going to work. (b) I changed the database table prefix in the wp-config.php file from wp1 to wp2; this caused wp to reinstall again into new database tables. (c) Then, using the MySQL Admin tool, I dropped the wp2 tables (the ones just generated, except for wp2_users) and then renamed the wp1 tables with the wp2 prefix. I kepted the new wp2_users table with the new admin account data (I, of course, didn’t want to bring over any corrupt data from wp1_users).

    This worked, essentially it created an entirely new website and database schema, but then overlayed the new db schema with the old tables/data except for the user table/data.

    Nothing, else I tried worked. I did try updating the admin user’s password (user_pass) on the wp1_users table, but that didn’t work.

    Anyways, my wife has her blog back with no data loss, just got to put some widgets back in (but those needed to be clean up anyway.

    MySQL Admin tool:
    http://www.mysql.com/products/tools/administrator/

    i can access my blog (www.sekarangbelajarsekarangbisa.comyr.com) but if i access wp-admin show login page from localhost.i cannot access wp-admin from my real blog.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Can’t access Admin’ is closed to new replies.