Support » Localhost Installs » can’t acces from external

  • Hi
    on a web serveur (opensuse leap 42.3 ) with php7 ans mysql databases i have installed 4 instance
    one with joolma
    one with php
    2 with wordpress
    this is for test
    the instances ares under htdocs
    /test
    /glpi
    /blog
    /xxxxx

    my machine is available from external (redirection of ports)
    i can acces to GLPI, Joomla
    but for the two on wordpress (blog and xxxx) I can’t !!!
    I have try to update php from 5.5 to 5.7 but still wrong
    i have try to disable wp_cache .. no change ??
    can you help me ??
    regards

Viewing 1 replies (of 1 total)
  • I think that your problem is with what URL you are using on a computer other than the host on your local LAN, and how your web server is configured.

    This is what I would do in your situation:
    – Your server needs to have a fixed IP address n your LAN, it can be anything so long as it is fixed, say it is “192.168.11.21”, go into the DHCP server settings on your LAN’s router and configure this.
    – assuming apache2 webserver
    – say that your four web projects will be accessed (from both localhost and the external computer (on your LAN)) as:
    a) joomla: http://joomla.test/
    b) php: http://php.test/
    c) WordPress #1: http://devwp.testing/
    d) WordPress #2: http://anotherwp.local/
    – I am not familiar with opensuse (I use Ubuntu), so say that the docs are in “/var/www/htdocs/”
    – In the server’s apache2 configuration file put these entries, in ubuntu it is at: “/etc/apache2/sites-enabled/001-local”

    <VirtualHost *:80>
    DocumentRoot /var/www/htdocs/joomla
    ServerName joomla.test
    ServerAlias www.joomla.test
    </VirtualHost>
    <VirtualHost *:80>
    DocumentRoot /var/www/htdocs/glpl
    ServerName php.test
    ServerAlias www.php.test
    </VirtualHost>
    <VirtualHost *:80>
    DocumentRoot /var/www/htdocs/blog
    ServerName devwp.testing
    ServerAlias www.devwp.testing
    </VirtualHost><VirtualHost *:80>
    DocumentRoot /var/www/htdocs/xxxxx
    ServerName anotherwp.local
    ServerAlias www.anotherwp.local
    </VirtualHost>

    Then restart your web server.
    -Now in your “hosts” file on your server add these entries:

    192.168.11.21  joomla.test
    192.168.11.21 www.joomla.test
    192.168.11.21 php.test
    192.168.11.21 www.php.test
    192.168.11.21 devwp.testing
    192.168.11.21 www.devwp.testing
    192.168.11.21 anotherwp.local
    192.168.11.21 www.anotherwp.local

    And in the hosts file on any computer on the same LAN segment, details here: http://en.wikipedia.org/wiki/Hosts_%28file%29

    127.0.0.1  joomla.test
    127.0.0.1 www.joomla.test
    127.0.0.1 php.test
    127.0.0.1 www.php.test
    127.0.0.1 devwp.testing
    127.0.0.1 www.devwp.testing
    127.0.0.1 anotherwp.local
    127.0.0.1 www.anotherwp.local

    – Configure your WordPress sites to use site-address and wordpress-address as

    devwp.testing
    anotherwp.local

    respectively.

    Now your webserver will be able to server your websites.
    Please report how this works for you.

Viewing 1 replies (of 1 total)
  • The topic ‘can’t acces from external’ is closed to new replies.