Support » Plugin: Yoast SEO » Canonical Tag Not Working Properly

  • Resolved astutechris

    (@astutechris)


    Yoast won’t add canonical tag to custom taxonomies types even after adding the link in the canonical field in the advanced setting, it still won’t show up when I view page source.

    Can anybody help with that?

    Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support devnihil

    (@devnihil)

    If you clear your cache (server, plugin, or CDN such as Cloudflare) does this resolve the issue? If you are not sure how to clear your server cache you should speak with your host provider.

    If you have cleared the site cache and the issue is still present, can you please provide us with a URL of where this is occurring so we can check into this further?

    Yes I cleared all cache but the issue persisted.

    Here is one of URLs that is having the issue: https://www.nairabargain.com/br/loja/cupons-gearbest/

    Plugin Support Michael Tina

    (@mikes41720)

    Can you please check whether you’ve added or used a filter that disabled the canonical output? You can refer to this article for more information — https://kb.yoast.com/kb/canonical-urls-in-wordpress-seo/

    To the best of my knowledge, I haven’t done any such thing. The canonical URL shows on other pages except the custom taxonomies.

    Plugin Support Michael Tina

    (@mikes41720)

    It’s possible that it could be a plugin or theme conflict. Can you try and gather as much information for us as possible? Please perform the following:

    1. Make sure the issue doesn’t persist when Yoast SEO is disabled.
    2. Check for conflicts.
    3. Check for JavaScript errors with your console.

    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new GitHub issue for our developers. Please report the issue to a third party developer as well.

    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    hi ,i have a problem with yoast seo pernmium plugin , i installed the last version 8.3 , now when i insert 3 or more canonical words and then save it , saving doesn’t complete and error 403 forbidden appears , could anyone help me?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Canonical Tag Not Working Properly’ is closed to new replies.