WordPress.org

Support

Support » Plugins and Hacks » Canonical error when W3 Total Cache enabled

Canonical error when W3 Total Cache enabled

  • Hi,

    I know I made a configuration error with W3 Total Cache and that it is not a W3 bug or issue, I love how much this plugin speeds everything up. My problem is I ran into a Canonical issue when I ran some standard checks after finishing W3 setup. When W3 is enabled http://www.zypath.com doesn’t work it just gives some garbage (a few lines of raw html), zypath.com runs like a champ. When I disable W3 and reboot HTML, MySQl and PHP http://www.zypath.com resolves to zypath.com in the browser whithout a problem. I notice the problem with Firefox and Safari browsers, chrome seems to work no matter what. I am clearing all cookies and testing with other devices such as a kindle and the problem is repeatable. So I know I did something stupid…

    Everything in DNS point to zypath.com, there is ‘A’ a record pointing zypath.com to an IP address and a CNAME pointing http://www.zypath.com to zypath.com. I did try to use virtual host on Apache2 but this caused access forbidden errors (even though I did add the access to the directory in the virtual hosts settings). Instead of adding too many variables I went back to looking at W3 (and stop playing with virtual hosts in apache2) and could not figure out why it made this stop working.

    Any suggestions would be appreciated.

    Thanks

    https://wordpress.org/plugins/w3-total-cache/

  • The topic ‘Canonical error when W3 Total Cache enabled’ is closed to new replies.