Support » Plugin: Yoast SEO » Canonical adds trailing slas by default

  • Resolved voodoochill

    (@voodoochill)


    My permalink settings do not have a training slash, but I just noticed that Yoast seems to add a trailing slash by default.

    Is there a way to disable the trailing slash – I have been advised that there should be consistency otherwise every page has a redirect canonical which I have been advised is not ideal (although I suppose not a disaster).

    Or would I be better of changing my permalink structure to have the trailing slash? And if so then I presume also all internal links (not sure how I’d do that).

Viewing 10 replies - 1 through 10 (of 10 total)
  • dieter93

    (@dieter93)

    Same here – please explain what is best to do.
    Thanks

    Plugin Support martijnvaneeghem

    (@martijnvaneeghem)

    Hi @voodoochill,

    We’re really sorry this has happened. We’ve been working hard to resolve all the issues that have been reported. You can read more about that in our blog post.

    Your issue has been resolved with the 14.0.2 release. Currently, we’re on release 14.0.4. Can you update to that latest version and see if that resolves the issue?

    After updating, you may need to run the indexation again via the Tools Tab in your Yoast SEO plugin. For sites with more than 10,000 posts, we advise using the WP CLI command to do the indexation on the server.

    If you cannot use the button, then you may need to:
    1. Install & activate the Yoast Test Helper plugin
    
2. Go to Tools -> Yoast Test

    3. Hit the “Reset indexables & migrations” button

    4. Try the optimize button again

    dieter93

    (@dieter93)

    This workaround ist not working for me.
    Tralingslash are already there 🙁

    Before version 14 everything was OK and now i have many websites with this problem.

    Do you have any other suggestions to fix the problem?

    Does this problem have a major impact on Google’s ranking?

    I am very confused right now.

    voodoochill

    (@voodoochill)

    Hit the “Reset indexables & migrations” button


    I didn;t have that button, but there were a couple of others I clicked.

    It’s all looking good now, thanks!

    dieter93

    (@dieter93)

    I use permalink-manager-pro to remove the trailing slash.
    As I said before, Yoast also displayed the canonical-url without trailing-slash before version 14.

    Today I checked my permalink settings in WordPress (not in permalink-manager-pro).
    I had the setting: Post name which outputs the following: https://example-domain/%postname%/ (https://example-domain/sample-post/)

    I did a test today and changed to the Custom Structure as follows:
    https://example-domain/%postname% (https://example-domain/sample-post)

    And now Yoast is showing the canonical-url again without a trailing slash.

    Everything seems to be okay now but I’m still a little bit shaken up. I spent all day today.

    Maybe someone can explain to me why Yoast previously displayed the canonical-url correctly with the permalink-manager-pro and now doesn’t do it anymore?

    A answer from a plugin manager would be very helpful.

    Thank you

    Plugin Support Carl B

    (@devnihil)

    @voodoochill Thanks for confirming that your issue has been resolved.

    @dieter93 We aren’t sure why you would be experiencing that issue with the Permalink Manager Pro plugin. Can you please confirm that the Permalink Manager Pro plugin is using the most current version?

    It seems to work with the latest update of the Permalink Manager. The author has probably added some extra adjustments regarding Yoast 14.x.

    Thanks a lot

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    @dieter93 Nice, we are glad to hear that the issue is now resolved 😀

    @voodoochill We apologies for any inconvenience. Can you please confirm whether you’re running the most recent version of Yoast SEO v14.0.4? If yes, can you please confirm that whether your permalinks structure is currently in the default structure or using a pretty structure?

    We can confirm the relevant bug was fixed in Yoast SEO v14.0.2. You can find the relevant pull request and more information here.

    Plugin Support Jerlyn

    (@jerparx)

    Hi @voodoochill ,

    We’re closing this thread because we haven’t heard back from you in a while. Should you have further questions, please open a new thread.

    veptune

    (@veptune)

    Hello all,

    I got exactly the same issue. Yoast add a slash in the canonical URL tag, even if the URL has no slash. I updated to the last version Version 14.8

    The issue is still there (of course I have clear all possible cache)

    Thanks you for your help.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.