Support » Plugin: WP Encrypt » Cannot write to temporary file

  • Resolved ma_wordpressorg

    (@ma_wordpressorg)


    I’ve sucessfully installed the plugin and also the account registation went through smoothly. But upon certificate generation, this error came up:
    Could not write CSR configuration to temporary file. Please check your filesystem permissions.
    I’m clueless. Where is this Configuration stored?
    I already checked for the .well-known directory and the ../letsencrypt folder is also already present.
    phpinfo gives me some locations for temporary stuff, but I’m not sure, if that is the place, where the plugin wants to store it’s configuration.
    I tried to change permissions for wp-content and the uploads folder inside it – no effect (even tried 777).
    I’m on a shared hosting environment (webpack at hosteurope) – maybe this doesn’t work at all?
    Any suggestions where to start?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter ma_wordpressorg

    (@ma_wordpressorg)

    I solved my problem with a change in my configuration.
    I added these lines into my wp-config.php

    putenv('TMPDIR=/mytempfolder/');
    define('WP_TEMP_DIR', '/mytempfolder/');

    After this installation went through without any warning.
    After that, I installed the certificates within the Hosteurope KIS and was encrypted one minute later. Thank you!

    This leaves me with one question: Is it possible to use the uploads folder for temporary actions instead of the servertemp?

    Plugin Author Felix Arntz

    (@flixos90)

    Hi, thanks for the report. I’m glad you could fix it yourself! 🙂

    It should be possible to use the uploads folder by passing it to the above environment var/constant like you did. I can’t think of anything that would prevent it.

    Thread Starter ma_wordpressorg

    (@ma_wordpressorg)

    mytempfolder is my wordpress root directory next to wp-config.php etc.
    What error-messages do you have?

    Thread Starter ma_wordpressorg

    (@ma_wordpressorg)

    I had an ftp-User and the permissons of that folder were 770. However – this was only a workaround to make the plugin generate the certificate. I still have to manually paste the certificate into Host-Europes KIS.

    Well, this brings me to the question: Did you also manually integrate your certificate into the KIS?
    Because the plugin does not give you the ability to automate that process. And there is also no way to integrate more than one domain into your certificate.

    I tried with these permissions too and yes, I had to integrate it manually. Are you able to use the regenerate feature? The zerossl.com route allows to integrate several domains. I think I will be looking into hosting providers with let”s encrypt support. Thank you!

    Thread Starter ma_wordpressorg

    (@ma_wordpressorg)

    That would also have been my suggestion.
    I have another customer, where the hoster integrates letsencrypt into its backend with autoregenerate and everything.
    But I see HostEuropes point: They want to sell their SSL.

    And I am able to use the regenerate feature, but I have to switch back to http for the process, because another error pops up.
    So basically regenerating my certificate with thisn plugin looks like this:
    1. Set my site to http
    2. Regenerate the certificate
    3. Download it with FTP
    4. Insert it into HE
    5. Switch back to https

    Not really comfortable, but for now, I’m living with it.
    But I want to integrate my other domains as well, which brings me back to another hoster or another way to regenerate my certificates.
    All a work in progress, I’d say.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Cannot write to temporary file’ is closed to new replies.