Support » Plugin: Yoast SEO » Cannot use %%page%% in static front page

  • Resolved Svard

    (@svard)


    My sub page have duplicate title tags and meta description so I try to add %%page%% in the static front page snippet and in the meta description. It don’t work.
    I do the same in the static blog page and it works fine, both in the title and in the meta description.
    What can be wrong in the static front page?
    It works with %%id%%,
    I use Genesis with Metro Pro theme and version 4.8.2 of WP.
    Anyway I am impressed of your SEO plugin.
    Best regards
    /Rickard

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Did you verify the source code of your front page to check whether the value of the %%page%% appears correctly or not?

    Yes. In the snippet I write ...%%page%% %%id%% and the code look like this in page 2 – http://itcsn.se/page/2/

    <title>| ITCSN | - IT Consult & Support North AB 257</title>

    The number 257 is the id, the page number is missing.

    /Rickard

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We are not sure why the %%page%% template variable fails to be outputted into the source code for paginated archive pages like http://itcsn.se/page/2/.

    We are not sure if it is the theme or the set-up or if it is something else.

    A. If you go to Settings->Reading and change it from a static page to “Your latest posts” does the issue resolve?

    B. If not, that sounds like a plugin or theme conflict. We ask that you please check for conflicts using this guide: https://kb.yoast.com/kb/how-to-check-for-plugin-conflicts


    If you find there is a conflict with a plugin or a theme, you can create a new GitHub issue here: https://github.com/Yoast/wordpress-seo/issues/ for our developers. Please report the issue to a third party developer as well.

    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium here: https://yoast.com/wordpress/plugins/seo/ and receive our Premium email support and we can help you further.

    Thank you for very god support.
    I find the template variable %%pagenumber%%works on my site itcsn.se and I am pleased with it. Of course your recommendation to disable all plugins and enable one at a time is a huge work and I will do it when I get economically independent. Meanwhile I use the %%pagenumber%%.
    You can close the case for now, even if it don’t really solved the cause on the issue but I find a workaround.
    Sincerely to you and your colleagues

    Rickard Svärd

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Cannot use %%page%% in static front page’ is closed to new replies.