Support » Plugin: OMGF | Host Google Fonts Locally » Cannot use it!

  • Resolved thornsteps

    (@thornsteps)


    I used the free version.

    Our website use system font (instead of Google Fonts) when activated the OMGF plugin.

    I doubt that the OMGF inject font script after the main css file.

    For example:

    LINE 67 – Main CSS File : <link data-wpacu-style-handle=’elementor-post-32809′ rel=’stylesheet’ id=’elementor-post-32809-css’ href=’XXX/post-32809.css’ type=’text/css’ media=’all’ />

    LINE 75 – OMGF Font Script : <link data-wpacu-style-handle=’google-fonts-1′ rel=’stylesheet’ id=’google-fonts-1-css’ href=’XXX/uploads/omgf/google-fonts-1/google-fonts-1.css’ type=’text/css’ media=’all’ />

    If it work, I would love to buy the PRO version.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    judging from the wpacu-style-handle attribute, you’re using Asset Cleanup or an equivalent?

    What happens when you disable that (temporarily)? I’d like to see if some setting in Asset Cleanup might be messing with OMGF’s stylesheet.

    Also, which theme are you using?

    Thread Starter thornsteps

    (@thornsteps)

    I deactivated both Asset CleanUp and iThemes Security.

    It’s still use system font.

    I use SitePoint Base Theme.

    You suspension on some plugin is breaking it?

    I saw the OMGF font scirpt (google-fonts-1) loading fonts normally in Chrome Dev Tool > Network. But some how that fonts did not apply to the website.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Could you share your site’s URL? That way I can take a look myself.

    Btw. Next time, please use a more descriptive title. That way other people running into the same issue can easily find the solution.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Just to let you know, I just tested it with SitePoint Base Theme and OMGF is successfully detecting and replacing the fonts. No system fonts are shown on the frontend.

    So, it must be a compatibility issue with one of the plugins you’re using.

    Thread Starter thornsteps

    (@thornsteps)

    I have disabled almost all the plugins excepting Elementor, Elementor Pro, Force Login, and WP Activity Log.

    Website still use system font.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Okay. And are you using any caching plugins or a CDN perhaps?

    Thread Starter thornsteps

    (@thornsteps)

    Okay, I tested download a font from https://google-webfonts-helper.herokuapp.com/fonts/prompt .

    Upload it to /wp-content/uploads/omgf/google-fonts-1 folder (override the old fonts)

    It’ work! It use that custom font.

    The bad news is I tested upload it with couple of fonts. It only works on 1 font style.

    Thread Starter thornsteps

    (@thornsteps)

    BTW, I don’t use CDN. I’m already clear cache.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Okay, I tested download a font from https://google-webfonts-helper.herokuapp.com/fonts/prompt .

    Upload it to /wp-content/uploads/omgf/google-fonts-1 folder (override the old fonts)

    It work!

    Awesome! But does that mean that, before you downloaded it manually, there were no other font files present in that folder?

    Thread Starter thornsteps

    (@thornsteps)

    OMGF already downloaded all fonts to the folder. I just rename and replace the font files.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Cannot use it!’ is closed to new replies.