Support » Plugin: Yoast SEO » Cannot upload images within posts

  • Resolved gregy1403

    (@gregy1403)


    Hi

    Strange thing happened today .. all of sudden I cannot upload featured image in post .. when I go to add image i can choose from library, i can also upload to library separatly, but when i click Upload (from PC) page where it shoudl say “Choose from disk” it is blank page.

    When I disable Yoast SEo, everything works … really no idea 🙁

Viewing 4 replies - 1 through 4 (of 4 total)
  • To get a better view, open your browser console and see what appears there when you try to upload an image.

    Also, check your error_log and wp-admin/error_log files for any relevant messages.

    If you find anything, paste it here.

    Thread Starter gregy1403

    (@gregy1403)

    a day after it works again 🙂 .. misterious ways 😀 thank you anyway for quick response

    Thread Starter gregy1403

    (@gregy1403)

    here we go again 🙁

    Console
    Uncaught TypeError: Cannot convert undefined or null to object
    at g.cleanup (load-scripts.php?c=0&load[chunk_0]=hoverIntent,common,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,postbox,admin-bar,heartbeat,autosave,sugge&load[chunk_1]=st,wp-ajax-response,jquery-color,wp-lists,jquery-ui-position,jquery-ui-menu,jquery-ui-autocomplete,tags-suggest,tags-box,undersc&load[chunk_2]=ore,word-count,wp-sanitize,post,editor-expand,thickbox,shortcode,backbone,wp-util,wp-backbone,media-models,wp-plupload&ver=5.3:437)
    at g.off (load-scripts.php?c=0&load[chunk_0]=hoverIntent,common,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,postbox,admin-bar,heartbeat,autosave,sugge&load[chunk_1]=st,wp-ajax-response,jquery-color,wp-lists,jquery-ui-position,jquery-ui-menu,jquery-ui-autocomplete,tags-suggest,tags-box,undersc&load[chunk_2]=ore,word-count,wp-sanitize,post,editor-expand,thickbox,shortcode,backbone,wp-util,wp-backbone,media-models,wp-plupload&ver=5.3:437)
    at r (load-scripts.php?c=0&load[chunk_0]=hoverIntent,common,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,postbox,admin-bar,heartbeat,autosave,sugge&load[chunk_1]=st,wp-ajax-response,jquery-color,wp-lists,jquery-ui-position,jquery-ui-menu,jquery-ui-autocomplete,tags-suggest,tags-box,undersc&load[chunk_2]=ore,word-count,wp-sanitize,post,editor-expand,thickbox,shortcode,backbone,wp-util,wp-backbone,media-models,wp-plupload&ver=5.3:437)
    at l (load-scripts.php?c=0&load[chunk_0]=hoverIntent,common,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,postbox,admin-bar,heartbeat,autosave,sugge&load[chunk_1]=st,wp-ajax-response,jquery-color,wp-lists,jquery-ui-position,jquery-ui-menu,jquery-ui-autocomplete,tags-suggest,tags-box,undersc&load[chunk_2]=ore,word-count,wp-sanitize,post,editor-expand,thickbox,shortcode,backbone,wp-util,wp-backbone,media-models,wp-plupload&ver=5.3:437)
    at h.Collection.n.off (load-scripts.php?c=0&load[chunk_0]=hoverIntent,common,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,postbox,admin-bar,heartbeat,autosave,sugge&load[chunk_1]=st,wp-ajax-response,jquery-color,wp-lists,jquery-ui-position,jquery-ui-menu,jquery-ui-autocomplete,tags-suggest,tags-box,undersc&load[chunk_2]=ore,word-count,wp-sanitize,post,editor-expand,thickbox,shortcode,backbone,wp-util,wp-backbone,media-models,wp-plupload&ver=5.3:437)
    at i.c.<computed> [as off] (media-views.min.js:1)
    at i.dispose (media-views.min.js:1)
    at i.dispose (media-views.min.js:3)
    at i.remove (media-views.min.js:1)
    at load-scripts.php?c=0&load[chunk_0]=hoverIntent,common,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,postbox,admin-bar,heartbeat,autosave,sugge&load[chunk_1]=st,wp-ajax-response,jquery-color,wp-lists,jquery-ui-position,jquery-ui-menu,jquery-ui-autocomplete,tags-suggest,tags-box,undersc&load[chunk_2]=ore,word-count,wp-sanitize,post,editor-expand,thickbox,shortcode,backbone,wp-util,wp-backbone,media-models,wp-plupload&ver=5.3:92

    @gregy1403 if you still think there’s a problem, set the thread to “unresolved” again.

    Also, when you paste errors (or code), you should enclose it in backticks (select what you’ve pasted and click the “CODE” link).

    For multi-line errors, put 3 backticks on a separate line, then paste, then put another line of 3 backticks.

    You might want to open an issue for this on https://github.com/Yoast/wordpress-seo/issues, but this may also be a WP 5.3 compatibility issue, if you’ve updated to it.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Cannot upload images within posts’ is closed to new replies.