Support » Plugin: CataBlog » Cannot Upload Images

  • Resolved nennisb

    (@nennisb)



    For a couple of months, I’ve been running into two issues when trying to upload a new item to Catablog:
    1. nonce error
    2. http 500 error

    I perused the support topics here and have seen both of these issues mentioned, but I have not seen a solution.

    What can I do as a work-around. This is obviously not a host issue, so please do not suggest that I contact my host.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Just one thing to add – I’ve tried uploading in Chrome (current version), Safari (current), and Firefox (current). Getting the same issues.

    Hi, can you share what specs is your server running? For example what PHP version and MySQL version is running in your server or are you using a Windows server?

    Also how large is the image you are uploading? Are you uploading one or more images at the same time? What type of image are you uploading.

    Thank you

    • This reply was modified 3 months, 2 weeks ago by  mbrsolution.

    The images are small (52 kb to 140 kb) and I am trying to load a single image at a time.

    Running PHP version: 5.6.36

    I hoped there would have been some sort of fix for this based on all the support topics created. Appreciate any insight you can give to correct this.

    Sarah

    Hi Sarah, please read what the developer said in another support thread.

    Kind regards

    So I am using Chrome, however, I’ve tried Firefox and Safari to no avail.

    Additionally, I have flash uploader disabled (apparently). It says, “Flash upload was not enabled. Either you elected to disable it, JavaScript is disabled, or your version of Flash is too old.”

    Is there a setting which I may change to be able to upload? Right now, I’m unable to upload anything.

    Thanks again!

    • This reply was modified 2 months, 3 weeks ago by  nennisb.

    Hi, I am able to upload images in my testing site. These are my specs.

    -Windows 10
    -Google Chrome version 66.0.3359.181 (Official Build) (64-bit)
    -I also have the following message displayed, “Flash upload was not enabled. Either you elected to disable it, JavaScript is disabled, or your version of Flash is too old.”
    -WordPress version 4.9.6
    -PHP Version : 5.6.32

    You will have to speak to your host about the following two errors.
    1. nonce error
    2. http 500 error

    Let me know what they say.

    Kind regards

    Okay, so I spoke with my host… Here’s what we know. The error:

    Fatal error: Allowed memory size of 327155712 bytes exhausted (tried to allocate 130968 bytes) in /home/ruffles2/public_html/wp-content/plugins/catablog/lib/CataBlogItem.class.php on line 808

    He disabled all other plugins and increased the available memory to 512mb and it still gave that out of memory error. It’s a quad core virtual dedicated server with 16gb of memory. This shouldn’t happen.

    Basically, he’s thinking there’s something amiss with the plugin. Thoughts?

    I’m the host.

    So I looked through your code, and I think it runs out of memory somewhere between the shrink_width and shrink_height functions. They call each other, and a loop in there may cause something like an endless memory leak.

    I don’t have time to work out the actual calculations – BUT previously, the thumbnail dimensions on the catablog options page were set to 220×220. I changed it to 222×220 and the error went away, and it appears to be working now. The image she was uploading was 800×800, if that helps you to troubleshoot.

    Hi @koppit, thank you for the information. I am sure this will help the developer troubleshoot this issue. Although he is already working on a solution to upload the images and not cause this type of issues in the future.

    @nennisb, I am glad your issue is resolved for now according to @koppit. Please remember to avoid uploading large scale size images for now until this issue is resolved by the developer.

    Kind regards

    nevermind. he updated 🙂

    Also, just in case anyone is having this problem, I want to be clear – I was trying to upload images that were 65 KB – tiny images – and was getting this error with the square thumbnail settings. 😉

    Thanks for all your help!

    • This reply was modified 2 months, 2 weeks ago by  nennisb.
    • This reply was modified 2 months, 2 weeks ago by  nennisb.

    You are most welcome 😉

    Can you mark this support thread as resolved if you don’t need any more help.

    Thank you

    resolved

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.