Support » Installing WordPress » Cannot upload image file when writing post

  • Hello

    I’m new to WordPress and I’m having a problem trying to upload an image file when writing a post. I get the message…

    “The uploaded file could not be moved to .”

    Can anyone give me a clue why this is happening?

    Cheers

    Mike O

Viewing 7 replies - 1 through 7 (of 7 total)
  • Mike I’m having the same problem, same situation. I set the permissions of the wp-content/uploads folder to 777 and still get the message when I try to upload an image.

    Perhaps when you upload an image there is no specifications as to where that image is to be sent. I guess the place to start would be in the options-upload area. I had problems earlier with loading my pictures once uploaded, but once I removed a “/” from the beginning of the directory where the picture was located…all was well.

    Is the folder above your uploads folder also set to 777? Also what kind of webserver are you using? I have that file uploads work brilliantly on Apache, but are not nearly as fun on IIS or Lighttpd.

    I am having this issue as well. Upon initial install, there was no uploads folder that I could see… even after creating an uploads folder manually using ftp, images are not placed there, and I still get the “images could not be moved to .” statement.

    The 1st time you use this /wp-content must be chmod 777 to create uploads folder and upload image – then revert back to chmod 755.

    I was able to chmod wp-content and it created the uploads folder, but still cannot move the image into it. I can see that the folder was created. I tried to chmod it to 777 but the server wouldn’t allow it. I am now getting the same message…

    The uploaded file could not be moved to .

    I checked the box “organize into subsets by month and year” in the options, and now get this error

    Unable to create directory /home/virtual/site36/fst/var/www/html/wordpress/wp-content/uploads/2006/11. Is its parent directory writable by the server?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cannot upload image file when writing post’ is closed to new replies.