Support » Fixing WordPress » Cannot upload files on wordpress

  • This is a self installed wordpress and I have been uploading files fine for months. I am the only person with access and I have no idea how this would have changed.

    When uploading files I am greeted by this:

    Unable to create directory /home/******/public_html/blog/wp-content/uploads/2009/01. Is its parent directory writable by the server?

    I have no idea why this would not work. when viewing the wp-content folder the permissions are still set to 755.

    Please help. I have no idea what could have gone wrong.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Check the permissions on the 2009 directory and the 01 directory in it…those two would have been created this month, so if this is the first time you tried to upload this year, maybe they were created with the wrong permissions. Just compare them to your 2008 directory and see if they are the same.

    also note, I have tried changing the permissions to 777 and the small jpeg file would still not upload with the same warning message.

    thank you so much figaro. It was the uploads folder that needed to be 777. It is weird that it was like that.

    Rock and roll sir!

    You’re welcome…glad you got it fixed.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Cannot upload files on wordpress’ is closed to new replies.