Support » Theme: Twenty Sixteen » Cannot Update to Latest Version

  • Update Failed: The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.

    This is the message I got when trying to update to the latest version of Twenty Sixteen. The same message happens in my theme editor for Twenty Seventeen and Twenty Nineteen, which are the other two WordPress Themes I have in my theme area, although I’m running Twenty Sixteen and have been successfully with every update until the one today? My site runs on Managed WordPress on GoDaddy.

    Plugins I am using are “Akismet”, “Classic Editor”, “Jetpack”, “Really Simple SSL”, “Relevanssi”, and “Scheduled Post Trigger”.

    The full message that appears when trying to update is: An error occurred while updating Twenty Sixteen: The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions. index.php, page.php, screenshot.png, single.php, css/ie7.css, css/ie.css, css/ie8.css, header.php, comments.php, genericons/Genericons.woff, genericons/README.md, genericons/LICENSE.txt, genericons/Genericons.ttf, genericons/genericons.css, genericons/COPYING.txt, genericons/Genericons.eot, genericons/Genericons.svg, rtl.css, searchform.php, js/skip-link-focus-fix.js, js/customize-preview.js, js/keyboard-image-navigation.js, js/html5.js, js/functions.js, js/color-scheme-control.js, search.php, archive.php, 404.php, sidebar.php, footer.php, image.php, sidebar-content-bottom.php, template-parts/content-page.php, template-parts/content-search.php, template-parts/biography.php, template-parts/content-single.php, template-parts/content-none.php, template-parts/content.php, inc/template-tags.php, inc/back-compat.php, inc/customizer.php

    Can anyone help with this?

    Sincerely,
    Andrew

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Update: I updated to PHP 7.2 from 7.1 and the theme update worked! Does the new updates require PHP 7.2? IF so, why didn’t WordPress tell its users to make sure to always run the latest PHP? I just find it strange that updating to PHP 7.2 made the update work successfully but on 7.1 it gave me all sorts of conflict errors with permissions? Hopefully someone will respond to this from the WordPress gurus…

    Update #2 – I tried posting a comment on anothe thread and for a response from a volunteer who said GoDaddy must have changed something else. But I verified the only thing changed was 7.1 to 7.2. And once changed, the update all WordPress themes latest versions including my active one, Twenty Sixteen, worked. At 7.1, they all failed with permission issues. The only thing I can think of is that it’s a combination of the shared server configuration and the PHP combination?

    WordPress core (and the standard themes) still don’t require PHP 7. (That will happen for new versions of core towards the end of 2019, but I doubt that the themes immediately will raise the same bar, since they still need to work nicely with previous version of WordPress core.)

    So: it might have been some temporary hiccup in your server environment. Could have been that you’ve got too little storage space left for temporary files, but if the core update went well, then I’m quite certain that this is not the problem.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.