WordPress.org

Forums

Cannot Update to 3.8.1. Could not copy files. Installation failed. (7 posts)

  1. dtlaadmin
    Member
    Posted 1 year ago #

    I'm trying to do the automatic update from version 3.5.2 to 3.8.1 and I am getting the error message below. I am new to WordPress and still learning, so the manual update seems too advanced for me at this time. Please, any help would be greatly appreciated!

    Warning: copy(/homepages/2/d480666746/htdocs/clickandbuilds/WordPress/conciergedtla/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: Permission denied in /homepages/2/d480666746/htdocs/clickandbuilds/WordPress/conciergedtla/wp-admin/includes/class-wp-filesystem-direct.php on line 200

    Could not copy files.

    Installation Failed

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    As you have such an old version of WordPress, you will need to carry out a series of smaller manual upgrades. See Upgrading_WordPress_Extended for the full details.

  3. dtlaadmin
    Member
    Posted 1 year ago #

    I knew that wasn't the best idea!

    I just screwed up our entire site. Please help me.

    I went through all the steps for Manual Updating and I got to Step 9. When I went to the WordPress admin page to log in I got a Error 404: NOT FOUND!
    This domain name has just been registered.

    Please help me resolve this.

    At this point I need to just restore the site as it was ASAP. The company really depends on the site and it is currently down!

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    So you couldn't run wp-admin/upgrade.php? If so, try re-uploading that version of WordPress again from a fresh download.

  5. dtlaadmin
    Member
    Posted 1 year ago #

    cannot update WordPress to version 3.8.1 because my theme is incompatible with it.

    When I try to update I get this error message:

    Warning: copy(/homepages/2/d480666746/htdocs/backup-wordpress/conciergedtla/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: Permission denied in /homepages/2/d480666746/htdocs/backup-wordpress/conciergedtla/wp-admin/includes/class-wp-filesystem-direct.php on line 200
    Could not copy files.

    Installation Failed

    I had the 1 & 1 support team help me update WordPress successfully to 3.8.1, but then my theme did not work with the new update. So we reverted back to the way it was with WordPress version 3.5.2 to get it working again.

    I'd like to update WordPress but I cannot lose this theme in the process. Any ideas?

  6. texxs
    Member
    Posted 1 year ago #

    @dtlaadmin
    You just need to bite the bullet and get a new theme or have the old one updated (it's most likely that your old theme is using an older version of jQuery).

    You also need to release that this will happen again at some point in the future, no matter what CMS you use and budget accordingly.

    typically we recommend that businesses update the layout (or theme) of their website every 1-2 years. Huge advanced in technology (and design happen very fast when it comes to the internet.

  7. moelangi
    Member
    Posted 1 year ago #

    I also need to update WP from 3.5.2 to WP 3.8.1. However it seems that I might end up in the same problem - using the old weaver theme, which I do not want to loose. Which theme do you use ? Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic