Support » Installation » cannot update to 3.3.1 on local installation

cannot update to 3.3.1 on local installation

  • After many tries I installed instant wordpress on my computer, which installs wordpress 3.2. I deactivated all plugins and renamed plugin folders, also deleted twenty ten theme, then tried to update to 3.3.1 automatically.
    Installation failed:
    “Could not copy file.: C:/Program Files/InstantWP_4.1/iwpserver/htdocs/wordpress/wp-content/upgrade/wordpress-3.tmp/”

    Instant WordPress developer says very difficult to upgrade manually.

    Can anyone give me some advice?
    thanks in advance

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Jan Dembowski


    Not sure how Instant WordPress handles Apache and file/directory permissions (but Instant WordPress sounds very cool and it’s on my to do list) but that’s usually a permissions issue.

    In your Windows Explorer locate the wp-content directory and try making it world writeable by granting Everyone Full control.

    It’s a bit lengthy but http://technet.microsoft.com/en-us/library/bb727008.aspx looks like a comprehensive walk through.

    Note: Normally I wouldn’t suggest that but it’s a localhost installation and I think it should be fine.

    (…It is a localhost installation right…?)

    thank you Jan, yes it’s om my computer. I changed security setting on wp-content folder per info in the link. I did not define objects though.

    When I try to auto upgrade I now get the same warning twice:

    Warning: copy(C:/Program Files/InstantWP_4.1/iwpserver/htdocs/wordpress/wp-admin/js/cat.dev.js) [function.copy]: failed to open stream: Permission denied in C:\Program Files\InstantWP_4.1\iwpserver\htdocs\wordpress\wp-admin\includes\class-wp-filesystem-direct.php on line 200

    I am not techie at all, so don’t understand what requirement means below “allows markup: a blockquote code em strong ul ol li. Put code between ‘backticks’. But I tried!

    Here is php in filesystem.direct:

    `<strong> <ul>
    <li> ‘function copy($source, $destination, $overwrite = false, $mode = false) {
    if ( ! $overwrite && $this->exists($destination) )
    return false;

    $rtval = copy($source, $destination);
    if ( $mode )
    $this->chmod($destination, $mode);’
    return $rtval;

    I’m guessing some or all of those “false” need to be “true”?

    thanks in advance for your advice

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘cannot update to 3.3.1 on local installation’ is closed to new replies.