WordPress.org

Support

Support » Installation » Cannot Update to 3.2 on Media Temple!

Cannot Update to 3.2 on Media Temple!

  • Media Temple is telling me that I have 5+ version of MYSQL but WordPress updater is says it is 4.1.25. Anyone else having this problems and is there a fix!!!

    thanks

Viewing 15 replies - 1 through 15 (of 39 total)
  • Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    Upload a phpinfo page to your site. If it says MySQL 4.1.25 there, send the link to Media Temple customer service so they can see.

    To create a phpinfo page, put this line in a file called test.php (or any other name with a .php extension):

    <?php phpinfo() ?>

    After uploading it, view the page in your browser. For example: http://www.yoursite.com/test.php

    You will see all your server specs there, including PHP & MySQL version.

    Just did… PHPINFO – says 5.0.32 there too!

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    That’s odd, then. I’m flagging this thread so a WP dev can have a look.

    esmi

    @esmi

    Forum Moderator

    PHP 5.0.32 isn’t good enough. You need 5.2.4 or later.

    @zoonini: Might be worth removing the needs-dev flag for the time being?

    The WORDPRESS install says you only need 5.0 or higher :

    You cannot update because WordPress 3.2 requires MySQL version 5.0 or higher. You are running version 4.1.25.

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    I thought the OP was saying his phpinfo file displays the MySQL version as 5.0.32.

    shawnsandy05 – can you provide a link to your phpinfo page?

    INFO: [removing link for security reasons for now – zoonini]

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    Indeed, looks like you’ve got MySQL 5.0.32 running.

    I’m re-flagging this with needs-dev for now.

    @zoonini Thnx, was a bit worried about that link…

    Will attempt a manual upgrade on a staging site and see what happens…

    So far the manual install worked I will continue testing for errors
    @esmi download says it requires

    MySQL 5.0.15 or greater (old requirement – since WordPress 2.9 was MySQL 4.1.2 or greater)

    Moderator Andrew Nacin

    @nacin

    Lead Developer

    If necessary, submit a support request to (mt) — they’re happy to help.

    @andrew : Does not seem that it is an MT problem as the manual install works so far and my database is using 5.0.32, 5.0.15 is required by WP 3.2… so I just cannot update using the WordPress auto update feature because it detects the incorrect version of MYSQL…

    I’m on MT and having the exact same problem. It’s stating that I’m running MySQL 4.1.25 but that’s really the version of Debian Linux that the server is running!
    I would REALLY appreciate if someone has a solution for this, even a hack…

    Screenshots:
    http://bit.ly/mPFqy0
    http://bit.ly/ojDNnm

    esmi

    @esmi

    Forum Moderator

    As suggested above, contact Media Temple.

    I’ve contacted MT but this doesn’t seem to be a host problem, all previous versions of WordPress upgraded just fine. Plus, if you look at my screenshots, you’ll see that WordPress is detecting the wrong number for MySQL version! It’s pretty obviously a WordPress issue.

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘Cannot Update to 3.2 on Media Temple!’ is closed to new replies.