Support » Localhost Installs » Cannot update most plugins

  • intexx

    (@intexx)


    I’m getting failures when I attempt to update most of my installed plugins. A very few of them do update successfully, but I’m not finding any indication of differences between the ones that do and the ones that don’t.

    Sometimes it’s an Internal Server Error, sometimes it’s this:

    Update failed: There has been a critical error on this website. Please check your site admin email inbox for instructions. Learn more about troubleshooting WordPress.

    The email never arrives, and there’s no link behind “Learn more.”

    I’m getting these entries in the Apache error log:

    [Tue Mar 30 16:00:17.837811 2021] [php:error] [pid 6004:tid 1836] [client ::1:2671] PHP Fatal error:  Uncaught Error: Unknown named parameter $tasks_meta_id in D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php:292\nStack trace:\n#0 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(316): WP_Hook->apply_filters('', Array)\n#1 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\plugin.php(551): WP_Hook->do_action(Array)\n#2 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\actions\\ActionScheduler_Action.php(22): do_action_ref_array('wpforms_process...', Array)\n#3 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\abstracts\\ActionScheduler_Abstract_QueueRunner.php(65): ActionScheduler_Action->execute()\n#4 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\ActionScheduler_QueueRunner.php(162): ActionScheduler_Abstract_QueueRunner->process_action(184, 'WP Cron')\n#5 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\ActionScheduler_QueueRunner.php(132): ActionScheduler_QueueRunner->do_batch(25, 'WP Cron')\n#6 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(292): ActionScheduler_QueueRunner->run('WP Cron')\n#7 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(316): WP_Hook->apply_filters('', Array)\n#8 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\plugin.php(551): WP_Hook->do_action(Array)\n#9 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-cron.php(138): do_action_ref_array('action_schedule...', Array)\n#10 {main}\n  thrown in D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php on line 292, referer: http://localhost:8080/wordpress/wp-cron.php?doing_wp_cron=1617148817.2128059864044189453125
    
    [Tue Mar 30 16:01:20.858314 2021] [php:error] [pid 6004:tid 1844] [client ::1:2540] PHP Fatal error:  Maximum execution time of 120 seconds exceeded in D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\Requests\\Transport\\cURL.php on line 163, referer: http://localhost:8080/wordpress/wp-admin/plugins.php

    However, I’m afraid this means nothing to me.

    How can I fix this so that I’ll be able to update my plugins? I’m running v5.7.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Are you using PHP8?

    try increase PHP max_execution_time and deactivate

    Thread Starter intexx

    (@intexx)

    I’m not sure which version of PHP I’m using. How would I determine this?

    I installed XAMPP/WP in this order:

    1. XAMPP v8.0.2
    2. XAMPP WordPress Module v5.6.2
    3. WordPress v5.7 Update

    You can check PHP info by creating a PHP file with the code <?php phpinfo(); ?> in it, then visit the php file from browser.

    Thread Starter intexx

    (@intexx)

    Got it, thanks.

    I’m running PHP v8.0.2.

    To clarify, are you suggesting I deactivate the plugin before attempting to update it? I neglected to point out that this is occurring on most plugins regardless of activation/deactivation status.

    How would I increase max_execution_time? I found several suggestions on how to do it at runtime, but that approach won’t work for this situation.

    Thread Starter intexx

    (@intexx)

    I increased max_execution_time to 300 and restarted apache, using this guidance:

    https://www.simplified.guide/php/increase-max-execution-time
    https://stackoverflow.com/a/11557220

    Unfortunately, however, it did not take. The process is still timing out after 120:

    [Thu Apr 01 09:47:26.444976 2021] [php:error] [pid 8260:tid 1824] [client ::1:7620] PHP Fatal error:  Uncaught Error: Unknown named parameter $tasks_meta_id in D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php:292\nStack trace:\n#0 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(316): WP_Hook->apply_filters('', Array)\n#1 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\plugin.php(551): WP_Hook->do_action(Array)\n#2 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\actions\\ActionScheduler_Action.php(22): do_action_ref_array('wpforms_admin_n...', Array)\n#3 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\abstracts\\ActionScheduler_Abstract_QueueRunner.php(65): ActionScheduler_Action->execute()\n#4 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\ActionScheduler_QueueRunner.php(162): ActionScheduler_Abstract_QueueRunner->process_action(211, 'Async Request')\n#5 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\ActionScheduler_QueueRunner.php(132): ActionScheduler_QueueRunner->do_batch(25, 'Async Request')\n#6 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(292): ActionScheduler_QueueRunner->run('Async Request')\n#7 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(316): WP_Hook->apply_filters('', Array)\n#8 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\plugin.php(484): WP_Hook->do_action(Array)\n#9 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\ActionScheduler_AsyncRequest_QueueRunner.php(52): do_action('action_schedule...', 'Async Request')\n#10 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\lib\\WP_Async_Request.php(156): ActionScheduler_AsyncRequest_QueueRunner->handle()\n#11 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(292): WP_Async_Request->maybe_handle('')\n#12 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(316): WP_Hook->apply_filters('', Array)\n#13 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\plugin.php(484): WP_Hook->do_action(Array)\n#14 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-admin\\admin-ajax.php(187): do_action('wp_ajax_as_asyn...')\n#15 {main}\n  thrown in D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php on line 292, referer: http://localhost:8080/wordpress/wp-admin/admin-ajax.php?action=as_async_request_queue_runner&nonce=35715369de
    [Thu Apr 01 09:48:31.412475 2021] [php:error] [pid 8260:tid 1828] [client ::1:7692] PHP Fatal error:  Uncaught Error: Unknown named parameter $tasks_meta_id in D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php:292\nStack trace:\n#0 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(316): WP_Hook->apply_filters('', Array)\n#1 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\plugin.php(551): WP_Hook->do_action(Array)\n#2 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\actions\\ActionScheduler_Action.php(22): do_action_ref_array('wpforms_admin_n...', Array)\n#3 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\abstracts\\ActionScheduler_Abstract_QueueRunner.php(65): ActionScheduler_Action->execute()\n#4 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\ActionScheduler_QueueRunner.php(162): ActionScheduler_Abstract_QueueRunner->process_action(213, 'WP Cron')\n#5 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\ActionScheduler_QueueRunner.php(132): ActionScheduler_QueueRunner->do_batch(25, 'WP Cron')\n#6 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(292): ActionScheduler_QueueRunner->run('WP Cron')\n#7 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(316): WP_Hook->apply_filters('', Array)\n#8 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\plugin.php(551): WP_Hook->do_action(Array)\n#9 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-cron.php(138): do_action_ref_array('action_schedule...', Array)\n#10 {main}\n  thrown in D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php on line 292, referer: http://localhost:8080/wordpress/wp-cron.php?doing_wp_cron=1617299310.6549110412597656250000
    [Thu Apr 01 09:49:43.439320 2021] [php:error] [pid 8260:tid 1832] [client ::1:7648] PHP Fatal error:  Maximum execution time of 120 seconds exceeded in D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\Requests\\Transport\\cURL.php on line 463, referer: http://localhost:8080/wordpress/wp-admin/plugins.php
    [Thu Apr 01 09:50:06.955711 2021] [php:error] [pid 8260:tid 1832] [client ::1:7766] PHP Fatal error:  Uncaught Error: Unknown named parameter $tasks_meta_id in D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php:292\nStack trace:\n#0 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(316): WP_Hook->apply_filters('', Array)\n#1 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\plugin.php(551): WP_Hook->do_action(Array)\n#2 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\actions\\ActionScheduler_Action.php(22): do_action_ref_array('wpforms_admin_n...', Array)\n#3 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\abstracts\\ActionScheduler_Abstract_QueueRunner.php(65): ActionScheduler_Action->execute()\n#4 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\ActionScheduler_QueueRunner.php(162): ActionScheduler_Abstract_QueueRunner->process_action(214, 'WP Cron')\n#5 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-content\\plugins\\wpforms-lite\\vendor\\woocommerce\\action-scheduler\\classes\\ActionScheduler_QueueRunner.php(132): ActionScheduler_QueueRunner->do_batch(25, 'WP Cron')\n#6 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(292): ActionScheduler_QueueRunner->run('WP Cron')\n#7 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(316): WP_Hook->apply_filters('', Array)\n#8 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\plugin.php(551): WP_Hook->do_action(Array)\n#9 D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-cron.php(138): do_action_ref_array('action_schedule...', Array)\n#10 {main}\n  thrown in D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php on line 292, referer: http://localhost:8080/wordpress/wp-cron.php?doing_wp_cron=1617299406.4644110202789306640625
    [Thu Apr 01 09:55:35.894803 2021] [php:error] [pid 8260:tid 1840] [client ::1:7844] PHP Fatal error:  Maximum execution time of 120 seconds exceeded in D:\\<PATH>\\apps\\wordpress\\htdocs\\wp-includes\\Requests\\Transport\\cURL.php on line 463, referer: http://localhost:8080/wordpress/wp-admin/plugins.php

    Nevertheless, I suspect two minutes ought to be plenty of time to update a plugin—I’m running an SSD under 16GB of system RAM. The timeout error seems to be a follow-on from the Unknown named parameter error. The former appears to be the real problem. I just don’t know how to decipher it.

    Interestingly, one of the previously failing (activated) plugins did update successfully just now. I have no idea why it suddenly worked this time.

    Plugin updates work fine on my hosted WP site. It’s only on localhost:8080 that they’re failing.

    • This reply was modified 2 weeks, 5 days ago by intexx.

    switch to PHP 7.4
    some plugins are not compatible with PHP 8 yet

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.