Support » Plugin: WP Google Maps » Cannot update map entries without saving whole page

  • Resolved BuddyBoy

    (@buddyboy)



    For some reason, all of a sudden, When adding address entries into my map the entry will not show up in the list until I actually save the whole map.

    Before I could add multiple entries and then save the map 1 time when I was finished. Now I have to save the map after every entry.

    Any idea what would cause this? I do have roughly 1k entries if that matters.

    Thanks in advance.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author perryrylance

    (@perryrylance)

    Hi there

    Thank you for getting in touch, sorry to hear you’re experiencing this issue.

    You definitely shouldn’t have to save the map after adding a marker in order to add more markers. Can you please open your developer console (usually F12) and add a marker, please tell us if any errors show up in the console?

    Kind regards
    – Perry

    BuddyBoy

    (@buddyboy)

    I get 2 errors:

    1) This API project is not authorized to use this API. Please ensure this API is activated in the Google Developers Console: https://console.developers.google.com/apis/api/places_backend?project=_ For more information on authentication and Google Maps Javascript API services please see: https://developers.google.com/maps/documentation/javascript/get-api-key

    2)wp-google-maps.min.js?ver=4.9.6:1 Uncaught Error: Latitude must be numeric
    at WPGMZA.LatLng.set (wp-google-maps.min.js?ver=4.9.6:1)
    at new WPGMZA.LatLng (wp-google-maps.min.js?ver=4.9.6:1)
    at Object.success (wpgmaps-admin-core.js?ver=7.10.05b:486)
    at i (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,thickbox,underscore,shortcode,media-upload,moxiejs,plupload&ver=4.9.6:2)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,thickbox,underscore,shortcode,media-upload,moxiejs,plupload&ver=4.9.6:2)
    at y (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,thickbox,underscore,shortcode,media-upload,moxiejs,plupload&ver=4.9.6:4)
    at XMLHttpRequest.c (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,thickbox,underscore,shortcode,media-upload,moxiejs,plupload&ver=4.9.6:4)

    Not sure if they’re related or not.

    Plugin Author perryrylance

    (@perryrylance)

    Hi there

    These are definitely related to the problem, can you please go to your Google dashboard as instructed by the error message in 1)

    Please see at the bottom of our documentation here for a list of the APIs you need to enable.

    I imagine the Geocoding API or another required API is switched off.

    Please let me know if that solves the problem?

    Kind regards
    – Perry

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.