Support » Plugin: Events Manager - OpenStreetMaps » Cannot update beyond 2.7.0 – PCLZIP_ERR_BAD_FORMAT

  • Resolved pwaring

    (@pwaring)


    Since 2.7.1 was released, I’ve been unable to update this plugin, either automatically using wp-cli (which I run every night) or via the admin dashboard. In both cases I get the following error:

    Warning: The package could not be installed. “PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature”

    This is happening on different sites and different servers. Other plugins have updated without a problem, so I don’t think it’s a problem with my setup.

    What is the best way to fix this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Stonehenge Creations

    (@duisterdenhaag)

    There is an issue in WP itself that if the stable version is not in the trunk, it claims the signature cannot be verified. Since I point to the stable tag folder, that might be it.

    Because you seem to be the only one of 500+ users that cannot update, I do think there is a difference in your setup, although I can not say for certain, not having access to your dashboard of course. 😉

    For now, I have completely reverted the code in 2.8.3. to be as 2.6.3. (See sticky topic I just posted).

    In your case, please deactivate the old version. Delete the plugin and re-install version 2.8.3 from the repository.

    While working out the bugs in the current/previous version I will look in to your update issue as well.

    Plugin Author Stonehenge Creations

    (@duisterdenhaag)

    Has this been solved with version 2.9.2?

    Plugin Author Stonehenge Creations

    (@duisterdenhaag)

    Since I got no response in almost 4 weeks, I am marking this topic as resolved.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cannot update beyond 2.7.0 – PCLZIP_ERR_BAD_FORMAT’ is closed to new replies.