Support » Fixing WordPress » Cannot type into text boxes for new posts

  • Resolved ipardoe


    I’m a new WordPress user with just the very beginnings of a site at I have searched in vain all day to find a solution to the problem I am having. As far as I can tell I have installed WordPress correctly, but when I try to add a new post or a new page the text box does not seem to respond correctly. Nothing seems to happen when I click in it (no blinking cursor) and if I type nothing appears (although if I then double click in the text box the text that I invisibly typed is highlighted). I have found previous references to this issue and have tried to follow all the suggested remedies, without success. In particular I have reinstalled WP, tried different browsers (the same thing happens with Chrome, Firefox, and IE), disabled plugins, and searched in vain for User > Personal Settings to enable HTTPS (has this been removed or moved with WordPress version 3.4.2?). I am now very frustrated and desperately hope someone can help.

Viewing 13 replies - 1 through 13 (of 13 total)
  • A quick guess from me is that it is JavaScript related. However this is normally only the case if you have installed theme and plugins. Which you should disable until you know your core installation is behaving normal.

    Have you activated a custom theme and installed plugins already?

    Thanks for the suggestions. Initially I did activate a custom theme (but did not install any plugins). However, I’ve reinstalled WordPress since then to see if that might fix my problem. Now I have (as far as I’m aware) a clean, untouched copy with just the Twenty Eleven theme (and still no plugins).

    If you are still getting the problem.

    Please also confirm your test results in Firefox, Chrome and Internet Explorer. This will rule out browser plugins.

    Also consider a header or footer your hosting adds to the page (view source if your not sure) however only free hosting usually does this so I doubt that is the case.

    Are you installing WordPress using hosting control panels copy of WordPress? Try another source whatever the case. It shouldn’t be the cause though. I doubt any hosting would let days pass with a core that has somehow been bugged at their end which is what would need to have happened.

    I consider everything as quick as I can 🙂

    Lastly is to check PHP version on your hosting package and ensure it is suitable. This also should not be the case but if you get this far and your still stuck. You’ll need to check everything you can.

    Thanks again for the quick advice. I looked at everything you suggested:

    – The same thing is happening in Chrome, Firefox, and IE.

    – My hosting does not seem to be adding a header or footer to the page.

    – I installed WordPress manually rather than through the hosting cPanel.

    – I just rooted around my cPanel but could not figure out the PHP version. I can try contacting the host ( to find out.

    A few more things I’ve noticed:

    – The fly-out menus on the dashboard don’t work consistently. When I first log in they don’t fly out at all. If I click one of the main menu items then the sub-menu items appear below as expected and the fly-out menus all start to work. However, if I then try something like adding a new page, the fly-out menus stop working again.

    – The Screen Options and Help links in the top right of each page don’t work.

    – Clicking on Visual or HTML on a Post or Page screen doesn’t do anything.

    It’s all kind of messed up.

    This is JavaScript related without a doubt. For it to be happening in 3 browsers, no plugins and WordPress default theme is very strange.

    What is your source of WordPress?

    You should search for any other WordPress users on with the same issue just to be sure.

    You really need to open the JavaScript error console. In Chrome it is in Tools in the main menu. Once opened on the Edit screen, refresh the screen. Upload a clear screenshot of all errors.

    Never heard of anyone having a problem with WordPress when no plugins or themes are in use other than default so I’m keen to figure this one out.

    Normally I use a Mac but I’m having to use a Windows computer just now and I’m embarrassed to admit that I don’t know quickly how to create a screenshot to upload. However, these are the errors that appeared in the console when I clicked on Add New Post and then tried clicking on the HTML tab:

    GET,hoverIntent,common,jquery-color,schedule,wp-ajax-response,autosave,suggest,wp-lists,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,postbox,post,thickbox,media-upload,word-count,editor,quicktags,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-button,jquery-ui-position,jquery-ui-dialog,wpdialogs,wplink,wpdialogs-popup,wp-fullscreen&ver=3.4.2 406 (Not Acceptable) post-new.php:593
    Uncaught ReferenceError: fullscreen is not defined wp-tinymce.php:27
    Uncaught ReferenceError: switchEditors is not defined post-new.php:231

    I forgot to say my source of WordPress was directly from

    Check the permissions (chmod) of all your folders, starting with the one holding JavaScript files.

    There is a folder named “js” in both wp-admin and wp-content. The one in wp-content has multiple folders in it so you may need to check each of them.

    I think they should be 0700 but you will need to confirm that yourself for security reason. I’ve never looked in the folder holding .js for jQuery UI but it appears WordPress is not permitted to access a folder and the required JavaScript files are not being loaded.

    It looks like all folders have a permission of 0755. Should I change all the folders to 0700 or just the js folders? And how do I do this? – I’m using FileZilla for my FTP client. (Sorry if these are very naive questions – I’m quite a bit out of my depth here.)

    Or another thing I was thinking of trying was reinstalling one last time, but this time using Softaculous rather than doing a manual install. Or would this be like trying to kill a fly with a missile (and with no real guarantee of it fixing my problem)?

    Whoah – someone at just fixed the problem! I’ll try to find out what they did.

    I thought it was the hosting. WordPress core does not have these kind of bugs. If no plugins installed and an issue happens on all browsers. Contact the hosting.

    Glad your sorted. said, “This was due to a mod_security rule, we have disabled it.”

    Thanks for all your help!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Cannot type into text boxes for new posts’ is closed to new replies.