WordPress.org

Support

Support » How-To and Troubleshooting » Cannot Switch Between Visual and HTML in editor

Cannot Switch Between Visual and HTML in editor

  • I’ll keep it short,

    I recently upgraded to 2.8,
    now I can’t switch between Visual and HTML
    I can access HTML if I go to users and disable visual… but thats the only way
    I tried Chrome… same issue, so its not a browser issue, cleared cache, restarted… still nothing

    I also tried redoing the upgrade

    ideas?

Viewing 15 replies - 1 through 15 (of 15 total)
  • I have the same problem with new version 2.8. I can’t access or switch to the visual editor.

    Same problem here. I am also unable to edit or post any new article.

    Same problem for me too..
    Help us!!!

    The problem was Google Gears!
    Remove your site from Google Gears’ settings and it works!

    Yes, Google Gears was the problem.

    I think I fixed the problem. I deactivated all the plugins, and the problem went away. Then, I started reactivating them one by one, verifying that i could still edit html on a test-post. When i activated “Use Google Libraries” the problem came back.

    Sorry, I forgot to refresh the page and I haven’t seen that an answer was already given.

    I dont have Google Gears installed on my computer or WordPress

    i disabled all my wordpress plugins, still no luck
    disabled all my firefox plugins and addons…no luck

    I can no longer publish any pages at all.

    As soon as I updated to version 2.8 the HTML editor stopped working. Also, when I publish a page it publishes as blank and removes anything I had in the visual editor.

    I have tried in several browsers and with all plugins disabled.

    I have never had Google Gears installed.

    Any suggestions would be greaty appreciated.

    The problem is NOT Google Gears. I don’t have Google Gears on either Firefox or IE, and I deactivated the “Use Google Libraries” plugin. The Visual editor is still non-functional.

    Is there an easy way to roll back to version 2.7?

    I upgraded to 2.8 last night and encountered the same problem with the visual editor being unavailable. After trying all the ideas listed here with no success, I thought I’d try to check the box in my user profile to ‘disable the visual editor when writing’. I did that, loaded the editor to confirm that it was in html mode. Then I went back into my profile and unchecked the box and tried again and the visual editor is now working in IE8 and Firefox 3.0.11.

    I hope this helps!

    Don
    grapelog.com

    we had the same problem and it was the Use Google Libraries plugin (mentioned in an earlier comment) Does anyone know a workaround? I’d like to still use that plugin if possible.

    oops correction, it wasn’t ‘use google libraries’ it was ‘google ajax libraries api plugin’ (could they have made that title longer?) The reason we changed to that from Use Google Libraries was because it was giving a different error… Do any of these google library plugins actually work?

    brent
    @
    mimoYmima.com

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Cannot Switch Between Visual and HTML in editor’ is closed to new replies.