Support » Plugin: qTranslate X » Cannot Switch Between Languages Anymore

  • Hey there,

    All of a sudden our members are having issues switching between languages, specifically from Spanish to English. Even typing in the URL with the appropriate code (/en) does not work. Sporadically it seems to work on Chrome but Firefox has been consistently not working. Have tried on multiple computers and same across all. Please advise. Thank you!

Viewing 13 replies - 1 through 13 (of 13 total)
  • You can try by going to and using the dropdown in the top-right to switch from English to Spanish…and then back to English. If I’m logged in, it will kick me out and take me to the homepage. If I’m not logged in, it will just refresh the page but stay in Spanish.

    Hey there,

    i’ve the same issue! Has someone a solution for this problem?

    Best regards,

    Tried updating to newest version of plugin, but that only made it worse.

    Any news on this? We had to remove the language switcher because people who switched from English to Spanish were unable to switch it back to English, causing a great deal of frustration. Please advise.

    The same happens to me, but not only with spanish-english also catalan-english catalan-spanish.
    it seems is just taking the last saved page as the good one for all the languages.
    You can check it at (it should be switching the language of the first line and the form)

    Sorry if it is not the same problem and it should be in a different topic, let me know and I’ll post it apart.

    Hi jjribs and florian,

    Just seen that this support forum is no longer answered by Gunu the plugin dev. Check out the new forum, there you can search topics better. I’ve posted a message relating to mi issue that I found out what it was.

    Hope this helps

    Thanks, I signed up for their new support forum but (I know this sounds like a stupid question) I cannot figure out how to add a new post. Can you direct me to the right place? Thanks!

    Yeap! First check if you are logged in, if not the new topic button is not shown. To log in you have to verify your account from the email you’d have received.

    Then choose one of the main forums, i.e. qTranslate X is this link

    Then at the top-right New topic


    got it, thanks!


    Were you able to fix this problem? Unfortunately, the forum from the link above doesn’t work.

    Thanks in advance!

    Hi @twilczak

    It didn’t work for me, the plugin gave me some problems like that so I switched to polylang.

    Hope you have better luck with it 😉


    Hi @anaplazas

    Thanks for your reply. I was considering switching the plugin but decided to give it one more try and it worked! I found a similar question in the FAQ and follow these suggestions:

    # Home URL does not switch language properly.

    If you test it with manual typing of language-neutral URL which gets redirected back to previously active language, then read “Browser re-direction based on language“.
    Check for anything funny in .htaccess file.
    Did you turn on option “Disable language client cookie ‘qtrans_front_language’ (not recommended).” on page /wp-admin/options-general.php?page=qtranslate-x#advanced? Then turn off option “Detect Browser Language” on page /wp-admin/options-general.php?page=qtranslate-x#general.

    In my case, there was something “funny” in .htaccess file. Somehow there was this weird redirection for default language. When I removed it, switching started working 🙂


    • This reply was modified 3 years, 10 months ago by twilczak.
    Plugin Author John Clause


    I am sorry for your trouble. We currently do not have resources to answer support questions for free and rely on the community to provide a possible solution, which seems to work well in many cases. Many thanks to our active community members who take a good time to answer people’s problems!

    Most of the problems should be resolvable with and, as well as many questions are addressed in FAQ,

    We need to figure out a way to monetize the support and further development. We would highly appreciate if you take about 5 minutes of your time to respond to the survey linked here:

    Any ideas and additional input are also welcome, use the same thread linked above for everyone to see your thoughts.

    Thanks a lot!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Cannot Switch Between Languages Anymore’ is closed to new replies.